Read the docs
TI-2024-15828 Aliases CVE-2024-23834

Discourse improperly sanitized user input leads to XSS

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Discourse is an open-source discussion platform. Improperly sanitized user input could lead to an XSS vulnerability in some situations. This vulnerability only affects Discourse instances which have disabled the default Content Security Policy. The vulnerability is patched in 3.1.5 and 3.2.0.beta5. As a workaround, ensure Content Security Policy is enabled and does not include `unsafe-inline`.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00487 42nd percentileScored 2026-11-07
Fix Fixed discourse (discourse): 3.1.5, 3.2.0.beta5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
discoursediscoursebefore 3.1.5; 3.2.0.beta1 to before 3.2.0.beta53.1.5, 3.2.0.beta5Patch availableCNA
  • discourse Vendordiscourse Affected before 3.1.5; 3.2.0.beta1 to before 3.2.0.beta5 Fixed in 3.1.5, 3.2.0.beta5 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:*before 3.1.5Vulnerablediscourse
cpe:2.3:a:discourse:discourse:*:*:*:*:beta:*:*:*before 3.2.0Vulnerablediscourse
cpe:2.3:a:discourse:discourse:3.2.0:beta1:*:*:beta:*:*:*3.2.0 beta1Vulnerablediscourse
cpe:2.3:a:discourse:discourse:3.2.0:beta2:*:*:beta:*:*:*3.2.0 beta2Vulnerablediscourse
cpe:2.3:a:discourse:discourse:3.2.0:beta3:*:*:beta:*:*:*3.2.0 beta3Vulnerablediscourse
cpe:2.3:a:discourse:discourse:3.2.0:beta4:*:*:beta:*:*:*3.2.0 beta4Vulnerablediscourse
  • cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:* Versions before 3.1.5 Vulnerable ·discourse
  • cpe:2.3:a:discourse:discourse:*:*:*:*:beta:*:*:* Versions before 3.2.0 Vulnerable ·discourse
  • cpe:2.3:a:discourse:discourse:3.2.0:beta1:*:*:beta:*:*:* Versions 3.2.0 beta1 Vulnerable ·discourse
  • cpe:2.3:a:discourse:discourse:3.2.0:beta2:*:*:beta:*:*:* Versions 3.2.0 beta2 Vulnerable ·discourse
  • cpe:2.3:a:discourse:discourse:3.2.0:beta3:*:*:beta:*:*:* Versions 3.2.0 beta3 Vulnerable ·discourse
  • cpe:2.3:a:discourse:discourse:3.2.0:beta4:*:*:beta:*:*:* Versions 3.2.0 beta4 Vulnerable ·discourse

Remediation

  • Fix · CNA discourse (discourse) Fixed in 3.1.5, 3.2.0.beta5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-23834

References

  • TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
  • TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
  • TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
  • TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
  • TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
  • TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
See all 262 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences