XSS in @apollo/experimental-nextjs-app-support
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
apollo-client-nextjs is the Apollo Client support for the Next.js App Router. The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this vulnerability, an attacker would need to either inject malicious input (e.g. by redirecting a user to a specifically-crafted link) or arrange to have malicious input be returned by a GraphQL server (e.g. by persisting it in a database). To fix this issue, please update to version 0.7.0 or later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| apollographql | apollo-client-nextjs | before 0.7.0 | 0.7.0 | Patch available | CNA |
| — | @apollo/experimental-nextjs-app-support (npm) | before 0.7.0 | 0.7.0 | Patch available | GHSA-rv8p-rr2h-fgpg |
- apollo-client-nextjs Vendorapollographql Affected before 0.7.0 Fixed in 0.7.0 Patch available CNA
- @apollo/experimental-nextjs-app-support (npm) Vendor— Affected before 0.7.0 Fixed in 0.7.0 Patch available GHSA-rv8p-rr2h-fgpg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apollographql:apollo_client:*:*:*:*:*:node.js:*:* | before 0.7.0 | Vulnerable | apollographql |
- cpe:2.3:a:apollographql:apollo_client:*:*:*:*:*:node.js:*:* Versions before 0.7.0 Vulnerable ·apollographql
Remediation
- Fix · CNA apollo-client-nextjs (apollographql) Fixed in 0.7.0
- Fix · GHSA-rv8p-rr2h-fgpg @apollo/experimental-nextjs-app-support (npm) Fixed in 0.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-23841
- 2026-10-03 Alias added: GHSA-rv8p-rr2h-fgpg
References
Advisory 2
Sources
- CVE-2024-23841 · CVE Program
- CVE-2024-23841 · NVD
- FIRST EPSS
- GHSA-rv8p-rr2h-fgpg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences