An issue was discovered in Django 3.2 before 3.2.24, 4.2 before 4.2.10, and Django 5.0…
Priority MEDIUM 42CWE-770Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 5 fixed, 8 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.
Summary
An issue was discovered in Django 3.2 before 3.2.24, 4.2 before 4.2.10, and Django 5.0 before 5.0.2. The intcomma template filter was subject to a potential denial-of-service attack when used with very long strings.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01606 76th percentileScored 2026-11-07
Fix Partial Django (PyPI): 3.2.24, 4.2.10, 5.0.2Red Hat: 5 advisoriesRed Hat: 5 fixed, 8 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 3.2 to before 3.2.24 | 3.2.24 | Patch available | GHSA-xxj9-f6rv-m3x4 |
| — | Django (PyPI) | 4.2 to before 4.2.10 | 4.2.10 | Patch available | GHSA-xxj9-f6rv-m3x4 |
| — | Django (PyPI) | 5.0 to before 5.0.2 | 5.0.2 | Patch available | GHSA-xxj9-f6rv-m3x4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 3.2 to before 3.2.24 Fixed in 3.2.24 Patch available GHSA-xxj9-f6rv-m3x4
- Django (PyPI) Vendor— Affected 4.2 to before 4.2.10 Fixed in 4.2.10 Patch available GHSA-xxj9-f6rv-m3x4
- Django (PyPI) Vendor— Affected 5.0 to before 5.0.2 Fixed in 5.0.2 Patch available GHSA-xxj9-f6rv-m3x4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 3.2 to before 3.2.24; 4.2 to before 4.2.10; 5.0 to before 5.0.2 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 3.2 to before 3.2.24; 4.2 to before 4.2.10; 5.0 to before 5.0.2 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-xxj9-f6rv-m3x4 Django (PyPI) Fixed in 3.2.24 Advisory →
- Fix · GHSA-xxj9-f6rv-m3x4 Django (PyPI) Fixed in 4.2.10 Advisory →
- Fix · GHSA-xxj9-f6rv-m3x4 Django (PyPI) Fixed in 5.0.2 Advisory →
Red Hat 5 advisories
- RHSA-2024:5662 Released 2024-08-20 · Red Hat rating ModerateSatellite 6.15.3 Security Update
- Red Hat Satellite 6.15 for RHEL 8 python-aiohttp-3.9.4-1.el8pc, python-django-4.2.14-1.el8pc, python-jinja2-3.1.4-1.el8pc +5
- RHSA-2024:2731 Released 2024-05-22 · Red Hat rating ModerateRed Hat OpenStack Platform 17.1 (python-django) security update
- Red Hat OpenStack Platform 17.1 python-django-2.2.24-8.el9ost, python3-django-2.2.24-8.el9ost
- RHSA-2024:1878 Released 2024-04-18 · Red Hat rating ModerateRHUI 4.8 Release - Security Updates, Bug Fixes, and Enhancements
- RHUI 4 for RHEL 8 python-aiohttp-3.9.2-1.el8ui, python-cryptography-41.0.6-1.el8ui, python-django-4.2.11-1.el8ui +7
Show 2 more Red Hat advisories
- RHSA-2024:1640 Released 2024-04-02 · Red Hat rating ModerateRed Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.4 for RHEL 8 automation-controller-venv-tower-4.5.5-2.el8ap, python39-aiohttp-3.9.3-1.el8ap, python39-django-4.2.11-1.el8ap +4
- Red Hat Ansible Automation Platform 2.4 for RHEL 9 automation-controller-venv-tower-4.5.5-2.el9ap, python-aiohttp-3.9.3-1.el9ap, python-django-4.2.11-1.el9ap +4
- RHSA-2024:1057 Released 2024-02-29 · Red Hat rating ImportantRed Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update
- Red Hat Ansible Automation Platform 2.4 for RHEL 8 ansible-automation-platform-installer-2.4-6.el8ap, ansible-rulebook-1.0.5-1.el8ap, automation-eda-controller-1.0.5-1.el8ap +14
- Red Hat Ansible Automation Platform 2.4 for RHEL 9 ansible-automation-platform-installer-2.4-6.el9ap, ansible-rulebook-1.0.5-1.el9ap, automation-eda-controller-1.0.5-1.el9ap +14
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 1.2 | Affected | No fix planned: Out of support scope |
| Red Hat Certification Program for Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Certification for Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Certification for Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 16.1 | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 16.2 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 18.0 | Affected | No fix yet |
| Red Hat Storage 3 | Affected | No fix planned: Out of support scope |
| RHUI 4 for RHEL 8 | Fixed | RHSA-2024:1878 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | Fixed | RHSA-2024:1057, RHSA-2024:1640 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 9 | Fixed | RHSA-2024:1057, RHSA-2024:1640 |
| Red Hat OpenStack Platform 17.1 | Fixed | RHSA-2024:2731 |
| Red Hat Satellite 6.15 for RHEL 8 | Fixed | RHSA-2024:5662 |
Not affected: 5 products
- RHUI 4 for RHEL 8
- Red Hat Ansible Automation Platform 2.4 for RHEL 8
- Red Hat Ansible Automation Platform 2.4 for RHEL 9
- Red Hat Discovery 1
- Red Hat Satellite 6.15 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-24680
- 2026-10-03 Alias added: GHSA-xxj9-f6rv-m3x4
References
Advisory 4
Other 13
- https://groups.google.com/forum/#%21forum/django-announce
- https://www.djangoproject.com/weblog/2024/feb/06/security-releases/
- https://github.com/django/django/commit/16a8fe18a3b81250f4fa57e3f93f0599dc4895bc
- https://github.com/django/django/commit/55519d6cf8998fe4c8f5c8abffc2b10a7c3d14e9
- https://github.com/django/django/commit/572ea07e84b38ea8de0551f4b4eda685d91d09d2
- https://github.com/django/django/commit/c1171ffbd570db90ca206c30f8e2b9f691243820
- https://docs.djangoproject.com/en/5.0/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2024-28.yaml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/D2JIRXEDP4ZET5KFMAPPYSK663Q52NEX
- https://lists.fedoraproject.org/archives/list/[email protected]/message/SN2PLJGYSAAG5KUVIUFJYKD3BLQ4OSN6
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZQJOMNRMVPCN5WMIZ7YSX5LQ7IR2NY4D
- https://www.djangoproject.com/weblog/2024/feb/06/security-releases
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-24680 · CVE Program
- CVE-2024-24680 · NVD
- FIRST EPSS
- GHSA-xxj9-f6rv-m3x4 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-24680 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences