Read the docs
TI-2024-16217 Aliases CVE-2024-24683GHSA-f6g6-pjgc-5cj5

Apache Hop Engine: ID isn't escaped when generating HTML

Priority LOW 31CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Improper Input Validation vulnerability in Apache Hop Engine.This issue affects Apache Hop Engine: before 2.8.0. Users are recommended to upgrade to version 2.8.0, which fixes the issue. When Hop Server writes links to the PrepareExecutionPipelineServlet page one of the parameters provided to the user was not properly escaped. The variable not properly escaped is the "id", which is not directly accessible by users creating pipelines making the risk of exploiting this low. This issue only affects users using the Hop Server component and does not directly affect the client.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01239 69th percentileScored 2026-11-07
Fix Fixed Apache Hop Engine (Apache Software Foundation): 2.8.0org.apache.hop:hop (Maven): 2.8.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Hop Enginebefore 2.8.02.8.0Patch availableCNA
—org.apache.hop:hop (Maven)before 2.8.02.8.0Patch availableGHSA-f6g6-pjgc-5cj5
  • Apache Hop Engine VendorApache Affected before 2.8.0 Fixed in 2.8.0 Patch available CNA
  • org.apache.hop:hop (Maven) Vendor— Affected before 2.8.0 Fixed in 2.8.0 Patch available GHSA-f6g6-pjgc-5cj5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:hop_engine:*:*:*:*:*:*:*:*before 2.8.0VulnerableApache
  • cpe:2.3:a:apache:hop_engine:*:*:*:*:*:*:*:* Versions before 2.8.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Hop Engine (Apache Software Foundation) Fixed in 2.8.0
  • Fix · GHSA-f6g6-pjgc-5cj5 org.apache.hop:hop (Maven) Fixed in 2.8.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-24683
  2. 2026-10-03 Alias added: GHSA-f6g6-pjgc-5cj5

References

Sources