WordPress PowerPack Pro for Elementor Plugin < 2.10.8 is vulnerable to Cross Site Request Forgery (CSRF)
Priority LOW 37CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in PowerPack Addons for Elementor PowerPack Pro for Elementor.This issue affects PowerPack Pro for Elementor: from n/a before 2.10.8.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0022 12th percentileScored 2026-11-07
Fix Fixed PowerPack Pro for Elementor (PowerPack Addons for Elementor): 2.10.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PowerPack Addons for Elementor | PowerPack Pro for Elementor | before 2.10.8 | 2.10.8 | Patch available | CNA |
- PowerPack Pro for Elementor VendorPowerPack Addons for Elementor Affected before 2.10.8 Fixed in 2.10.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:powerpackelements:powerpack_addons_for_elementor:*:*:*:*:pro:wordpress:*:* | up to 2.10.8 | Vulnerable | Powerpackelements |
- cpe:2.3:a:powerpackelements:powerpack_addons_for_elementor:*:*:*:*:pro:wordpress:*:* Versions up to 2.10.8 Vulnerable ·Powerpackelements
Remediation
- Fix · CNA PowerPack Pro for Elementor (PowerPack Addons for Elementor) Fixed in 2.10.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-24843
- 2026-10-03 Alias added: GHSA-xhch-ppc4-w2v4
Sources
- CVE-2024-24843 · CVE Program
- CVE-2024-24843 · NVD
- FIRST EPSS
- GHSA-xhch-ppc4-w2v4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences