Improper certificate validation in Apache Airflow Mongo Provider
Priority MEDIUM 48CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated. This was unexpected and undocumented. Users are recommended to upgrade to version 4.0.0, which fixes this issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00625 50th percentileScored 2026-11-07
Fix Fixed Apache Airflow Mongo Provider (Apache Software Foundation): 4.0.0apache-airflow-providers-mongo (PyPI): 4.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow Mongo Provider | 1.0.0 to before 4.0.0 | 4.0.0 | Patch available | CNA |
| — | apache-airflow-providers-mongo (PyPI) | before 4.0.0 | 4.0.0 | Patch available | GHSA-x5pm-h33q-cjrw |
- Apache Airflow Mongo Provider VendorApache Affected 1.0.0 to before 4.0.0 Fixed in 4.0.0 Patch available CNA
- apache-airflow-providers-mongo (PyPI) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-x5pm-h33q-cjrw
Remediation
- Fix · CNA Apache Airflow Mongo Provider (Apache Software Foundation) Fixed in 4.0.0
- Fix · GHSA-x5pm-h33q-cjrw apache-airflow-providers-mongo (PyPI) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-25141
- 2026-10-03 Alias added: GHSA-x5pm-h33q-cjrw
- 2026-11-03 EPSS moved to the 50th–90th percentile
References
Advisory 2
Sources
- CVE-2024-25141 · CVE Program
- CVE-2024-25141 · NVD
- FIRST EPSS
- GHSA-x5pm-h33q-cjrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences