A Server-Side Request Forgery (SSRF) vulnerability in the /Upgrade/FixConfig route in…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
A Server-Side Request Forgery (SSRF) vulnerability in the /Upgrade/FixConfig route in Open Library Foundation VuFind 2.0 through 9.1 before 9.1.1 allows a remote attacker to overwrite local configuration files to gain access to the administrator panel and achieve Remote Code Execution. A mitigating factor is that it requires the allow_url_include PHP runtime setting to be on, which is off in default installations. It also requires the /Upgrade route to be exposed, which is exposed by default after installing VuFind, and is recommended to be disabled by setting autoConfigure to false in config.ini.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | vufind/vufind (Packagist) | 2.0 to before 9.1.1 | 9.1.1 | Patch available | GHSA-wx24-vqrg-m6m5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- vufind/vufind (Packagist) Vendor— Affected 2.0 to before 9.1.1 Fixed in 9.1.1 Patch available GHSA-wx24-vqrg-m6m5
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openlibraryfoundation:vufind:*:*:*:*:*:*:*:* | — | — | Openlibraryfoundation |
- cpe:2.3:a:openlibraryfoundation:vufind:*:*:*:*:*:*:*:* Versions — — ·Openlibraryfoundation
Remediation
- Fix · GHSA-wx24-vqrg-m6m5 vufind/vufind (Packagist) Fixed in 9.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-25738
- 2026-10-03 Alias added: GHSA-wx24-vqrg-m6m5
References
Sources
- CVE-2024-25738 · CVE Program
- CVE-2024-25738 · NVD
- FIRST EPSS
- GHSA-wx24-vqrg-m6m5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences