Buffer Overflow vulnerability in eza before version 0.18.2, allows local attackers to…
Priority HIGH 72CWE-120Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-120 and the CVSS impact.
Summary
Buffer Overflow vulnerability in eza before version 0.18.2, allows local attackers to execute arbitrary code via the .git/HEAD, .git/refs, and .git/objects components.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00267 18th percentileScored 2026-11-07
Fix Fixed eza (crates.io): 0.18.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | eza (crates.io) | before 0.18.2 | 0.18.2 | Patch available | GHSA-3qx3-6hxr-j2ch |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- eza (crates.io) Vendor— Affected before 0.18.2 Fixed in 0.18.2 Patch available GHSA-3qx3-6hxr-j2ch
Remediation
- Fix · GHSA-3qx3-6hxr-j2ch eza (crates.io) Fixed in 0.18.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-25817
- 2026-10-03 Alias added: GHSA-3qx3-6hxr-j2ch
References
Sources
- CVE-2024-25817 · CVE Program
- CVE-2024-25817 · NVD
- FIRST EPSS
- GHSA-3qx3-6hxr-j2ch · GitHub Advisory Database · CC BY 4.0
- CVE-2024-25817 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences