EventStoreDB Projections Subsystem has potential password leak
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-256.
Summary
EventStoreDB (ESDB) is an operational database built to store events. A vulnerability has been identified in the projections subsystem in versions 20 prior to 20.10.6, 21 prior to 21.10.11, 22 prior to 22.10.5, and 23 prior to 23.10.1. Only database instances that use custom projections are affected by this vulnerability. User passwords may become accessible to those who have access to the chunk files on disk, and users who have read access to system streams. Only users in the `$admins` group can access system streams by default. ESDB 23.10.1, 22.10.5, 21.10.11, and 20.10.6 contain a patch for this issue. Users should upgrade EventStoreDB, reset the passwords for current and previous members of `$admins` and `$ops` groups, and, if a password was reused in any other system, reset it in those systems to a unique password to follow best practices. If an upgrade cannot be done immediately, reset the passwords for current and previous members of `$admins` and `$ops` groups. Avoid creating custom projections until the patch has been applied.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| EventStore | EventStore | 23.0.0 to before 23.10.1; 22.0.0 to before 22.10.5; 21.0.0 to before 21.10.11; 20.0.0 to before 20.10.6 | 23.10.1, 22.10.5, 21.10.11, 20.10.6 | Patch available | CNA |
- EventStore VendorEventStore Affected 23.0.0 to before 23.10.1; 22.0.0 to before 22.10.5; 21.0.0 to before 21.10.11; 20.0.0 to before 20.10.6 Fixed in 23.10.1, 22.10.5, 21.10.11, 20.10.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kurrent:eventstoredb:*:*:*:*:open-source:*:*:* | 20.10.0 to before 20.10.6; 21.10.0 to before 21.10.11; 22.10.0 to before 22.10.5; 23.10.0 to before 23.10.1 | Vulnerable | Kurrent |
- cpe:2.3:a:kurrent:eventstoredb:*:*:*:*:open-source:*:*:* Versions 20.10.0 to before 20.10.6; 21.10.0 to before 21.10.11; 22.10.0 to before 22.10.5; 23.10.0 to before 23.10.1 Vulnerable ·Kurrent
Remediation
- Fix · CNA EventStore (EventStore) Fixed in 23.10.1, 22.10.5, 21.10.11, 20.10.6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-26133
References
Other 4
- https://developers.eventstore.com/cloud/ops/#upgrading-eventstoredb-version
- https://developers.eventstore.com/server/v22.10/upgrade-guide.html#upgrade-guide-for-eventstoredb-22-10
- https://www.eventstore.com/blog/eventstoredb-security-release-23.10-22.10-21.10-and-20.10-for-cve-2024-26133
- https://www.eventstore.com/blog/new-version-strategy
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences