com.yetanalytics/lrs has Cross-site Scripting Vulnerability in Statement Browser
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| yetanalytics | lrs | before 0.7.5; before 1.2.17 | 0.7.5, 1.2.17 | Patch available | CNA |
| — | com.yetanalytics:lrs (Maven) | before 1.2.17 | 1.2.17 | Patch available | GHSA-7rw2-3hhp-rc46 |
- lrs Vendoryetanalytics Affected before 0.7.5; before 1.2.17 Fixed in 0.7.5, 1.2.17 Patch available CNA
- com.yetanalytics:lrs (Maven) Vendor— Affected before 1.2.17 Fixed in 1.2.17 Patch available GHSA-7rw2-3hhp-rc46
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yetanalytics:lrs:*:*:*:*:*:*:*:* | before 1.2.17 | Vulnerable | yetanalytics |
| cpe:2.3:a:yetanalytics:sql_lrs:*:*:*:*:*:*:*:* | before 0.7.5 | Vulnerable | yetanalytics |
- cpe:2.3:a:yetanalytics:lrs:*:*:*:*:*:*:*:* Versions before 1.2.17 Vulnerable ·yetanalytics
- cpe:2.3:a:yetanalytics:sql_lrs:*:*:*:*:*:*:*:* Versions before 0.7.5 Vulnerable ·yetanalytics
Remediation
- Fix · CNA lrs (yetanalytics) Fixed in 0.7.5, 1.2.17
- Fix · GHSA-7rw2-3hhp-rc46 com.yetanalytics:lrs (Maven) Fixed in 1.2.17 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-26140
- 2026-10-03 Alias added: GHSA-7rw2-3hhp-rc46
References
Advisory 2
Sources
- CVE-2024-26140 · CVE Program
- CVE-2024-26140 · NVD
- FIRST EPSS
- GHSA-7rw2-3hhp-rc46 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences