Rails Possible XSS Vulnerability in Action Controller
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Rails is a web-application framework. There is a possible XSS vulnerability when using the translation helpers in Action Controller. Applications using translation methods like translate, or t on a controller, with a key ending in "_html", a :default key which contains untrusted user input, and the resulting string is used in a view, may be susceptible to an XSS vulnerability. The vulnerability is fixed in 7.1.3.1 and 7.0.8.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Rails | rails | 7.0.0 to before 7.0.8.1; 7.1.0 to before 7.1.3.1 | 7.0.8.1, 7.1.3.1 | Patch available | CNA |
| — | actionpack (RubyGems) | 7.0.0 to before 7.0.8.1 | 7.0.8.1 | Patch available | GHSA-9822-6m93-xqf4 |
| — | actionpack (RubyGems) | 7.1.0 to before 7.1.3.1 | 7.1.3.1 | Patch available | GHSA-9822-6m93-xqf4 |
| — | rails (RubyGems) | 7.0.0 to before 7.0.8.1 | 7.0.8.1 | Patch available | GHSA-9822-6m93-xqf4 |
| — | rails (RubyGems) | 7.1.0 to before 7.1.3.1 | 7.1.3.1 | Patch available | GHSA-9822-6m93-xqf4 |
- rails VendorRails Affected 7.0.0 to before 7.0.8.1; 7.1.0 to before 7.1.3.1 Fixed in 7.0.8.1, 7.1.3.1 Patch available CNA
- actionpack (RubyGems) Vendor— Affected 7.0.0 to before 7.0.8.1 Fixed in 7.0.8.1 Patch available GHSA-9822-6m93-xqf4
- actionpack (RubyGems) Vendor— Affected 7.1.0 to before 7.1.3.1 Fixed in 7.1.3.1 Patch available GHSA-9822-6m93-xqf4
- rails (RubyGems) Vendor— Affected 7.0.0 to before 7.0.8.1 Fixed in 7.0.8.1 Patch available GHSA-9822-6m93-xqf4
- rails (RubyGems) Vendor— Affected 7.1.0 to before 7.1.3.1 Fixed in 7.1.3.1 Patch available GHSA-9822-6m93-xqf4
Remediation
- Fix · CNA rails (rails) Fixed in 7.0.8.1, 7.1.3.1
- Fix · GHSA-9822-6m93-xqf4 actionpack (RubyGems) Fixed in 7.0.8.1 Advisory →
- Fix · GHSA-9822-6m93-xqf4 actionpack (RubyGems) Fixed in 7.1.3.1 Advisory →
- Fix · GHSA-9822-6m93-xqf4 rails (RubyGems) Fixed in 7.0.8.1 Advisory →
- Fix · GHSA-9822-6m93-xqf4 rails (RubyGems) Fixed in 7.1.3.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet |
Not affected: 1 product
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-26143
- 2026-10-03 Alias added: GHSA-9822-6m93-xqf4
References
Exploit 3
Patch 2
Advisory 2
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2024-26143 · CVE Program
- CVE-2024-26143 · NVD
- FIRST EPSS
- GHSA-9822-6m93-xqf4 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-26143 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences