Read the docs
TI-2024-17612 Aliases CVE-2024-26736GHSA-vrrq-3f8j-8672

afs: Increase buffer size in afs_update_volume_status()

Priority LOW 36CWE-787Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.

Summary

In the Linux kernel, the following vulnerability has been resolved: afs: Increase buffer size in afs_update_volume_status() The max length of volume->vid value is 20 characters. So increase idbuf[] size up to 24 to avoid overflow. Found by Linux Verification Center (linuxtesting.org) with SVACE. [DH: Actually, it's 20 + NUL, so increase it to 24 and use snprintf()]

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00729 54th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.4.270, 5.10.211, 5.15.150 +4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux4.15 and later5.4.270, 5.10.211, 5.15.150, 6.1.80, 6.6.19, 6.7.7, 6.8Patch availableCNA
  • Linux VendorLinux Affected 4.15 and later Fixed in 5.4.270, 5.10.211, 5.15.150, 6.1.80, 6.6.19, 6.7.7, 6.8 Patch available CNA

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*4.15 to before 5.4.270; 5.5 to before 5.10.211; 5.11 to before 5.15.150; 5.16 to before 6.1.80; 6.2 to before 6.6.19; 6.7 to before 6.7.7VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:*6.8 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:*6.8 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:*6.8 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:*6.8 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:*6.8 rc5VulnerableLinux
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.15 to before 5.4.270; 5.5 to before 5.10.211; 5.11 to before 5.15.150; 5.16 to before 6.1.80; 6.2 to before 6.6.19; 6.7 to before 6.7.7 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* Versions 6.8 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* Versions 6.8 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* Versions 6.8 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* Versions 6.8 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* Versions 6.8 rc5 Vulnerable ·Linux
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.4.270, 5.10.211, 5.15.150, 6.1.80, 6.6.19, 6.7.7, 6.8

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 4 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-26736
  2. 2026-10-03 Alias added: GHSA-vrrq-3f8j-8672

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources