l2tp: pass correct message length to ip6_append_data
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-131 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: l2tp: pass correct message length to ip6_append_data l2tp_ip6_sendmsg needs to avoid accounting for the transport header twice when splicing more data into an already partially-occupied skbuff. To manage this, we check whether the skbuff contains data using skb_queue_empty when deciding how much data to append using ip6_append_data. However, the code which performed the calculation was incorrect: ulen = len + skb_queue_empty(&sk->sk_write_queue) ? transhdrlen : 0; ...due to C operator precedence, this ends up setting ulen to transhdrlen for messages with a non-zero length, which results in corrupted packets on the wire. Add parentheses to correct the calculation in line with the original intent.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19.296 to before 4.19.308; 5.4.258 to before 5.4.270; 5.10.198 to before 5.10.211; 5.15.135 to before 5.15.150; 6.1.57 to before 6.1.80; 4.14.327 to before 4.15; 6.5.7 to before 6.6 | 4.19.308, 5.4.270, 5.10.211, 5.15.150, 6.1.80, 4.15, 6.6 | Patch available | CNA |
| Linux | Linux | 6.6 and later | 4.19.308, 5.4.270, 5.10.211, 5.15.150, 6.1.80, 6.6.19, 6.7.7, 6.8 | Patch available | CNA |
- Linux VendorLinux Affected 4.19.296 to before 4.19.308; 5.4.258 to before 5.4.270; 5.10.198 to before 5.10.211; 5.15.135 to before 5.15.150; 6.1.57 to before 6.1.80; 4.14.327 to before 4.15; 6.5.7 to before 6.6 Fixed in 4.19.308, 5.4.270, 5.10.211, 5.15.150, 6.1.80, 4.15, 6.6 Patch available CNA
- Linux VendorLinux Affected 6.6 and later Fixed in 4.19.308, 5.4.270, 5.10.211, 5.15.150, 6.1.80, 6.6.19, 6.7.7, 6.8 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.19.296 to before 4.19.308; 5.4.258 to before 5.4.270; 5.10.198 to before 5.10.211; 5.15.135 to before 5.15.150; 6.1.57 to before 6.1.80; 6.6 to before 6.6.19; 6.7 to before 6.7.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:4.14.327:*:*:*:*:*:*:* | 4.14.327 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.5.7:*:*:*:*:*:*:* | 6.5.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* | 6.8 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* | 6.8 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* | 6.8 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* | 6.8 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* | 6.8 rc5 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.19.296 to before 4.19.308; 5.4.258 to before 5.4.270; 5.10.198 to before 5.10.211; 5.15.135 to before 5.15.150; 6.1.57 to before 6.1.80; 6.6 to before 6.6.19; 6.7 to before 6.7.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:4.14.327:*:*:*:*:*:*:* Versions 4.14.327 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.5.7:*:*:*:*:*:*:* Versions 6.5.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* Versions 6.8 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* Versions 6.8 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* Versions 6.8 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* Versions 6.8 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* Versions 6.8 rc5 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.308, 5.4.270, 5.10.211, 5.15.150, 6.1.80, 4.15, 6.6
- Fix · CNA Linux (Linux) Fixed in 4.19.308, 5.4.270, 5.10.211, 5.15.150, 6.1.80, 6.6.19, 6.7.7, 6.8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-26752
- 2026-10-03 Alias added: GHSA-xhj3-2vvm-6mr5
References
Patch 8
- https://git.kernel.org/stable/c/4c3ce64bc9d36ca9164dd6c77ff144c121011aae
- https://git.kernel.org/stable/c/c1d3a84a67db910ce28a871273c992c3d7f9efb5
- https://git.kernel.org/stable/c/dcb4d14268595065c85dc5528056713928e17243
- https://git.kernel.org/stable/c/0da15a70395182ee8cb75716baf00dddc0bea38d
- https://git.kernel.org/stable/c/13cd1daeea848614e585b2c6ecc11ca9c8ab2500
- https://git.kernel.org/stable/c/804bd8650a3a2bf3432375f8c97d5049d845ce56
- https://git.kernel.org/stable/c/83340c66b498e49353530e41542500fc8a4782d6
- https://git.kernel.org/stable/c/359e54a93ab43d32ee1bff3c2f9f10cb9f6b6e79
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-26752 · CVE Program
- CVE-2024-26752 · NVD
- FIRST EPSS
- GHSA-xhj3-2vvm-6mr5 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-26752 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences