speakup: Avoid crash on very long word
Priority LOW 34Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: speakup: Avoid crash on very long word In case a console is set up really large and contains a really long word (> 256 characters), we have to stop before the length of the word buffer.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00295 22nd percentileScored 2026-11-07
Fix Fixed Linux (Linux): 4.19.313, 5.4.275, 5.10.216 +5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.37 and later | 4.19.313, 5.4.275, 5.10.216, 5.15.157, 6.1.88, 6.6.29, 6.8.8, 6.9 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.37 and later Fixed in 4.19.313, 5.4.275, 5.10.216, 5.15.157, 6.1.88, 6.6.29, 6.8.8, 6.9 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.37 to before 4.19.313; 4.20 to before 5.4.275; 5.5 to before 5.10.216; 5.11 to before 5.15.157; 5.16 to before 6.1.88; 6.2 to before 6.6.29; 6.7 to before 6.8.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc1:*:*:*:*:*:* | 6.9 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc2:*:*:*:*:*:* | 6.9 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc3:*:*:*:*:*:* | 6.9 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc4:*:*:*:*:*:* | 6.9 rc4 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.37 to before 4.19.313; 4.20 to before 5.4.275; 5.5 to before 5.10.216; 5.11 to before 5.15.157; 5.16 to before 6.1.88; 6.2 to before 6.6.29; 6.7 to before 6.8.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc1:*:*:*:*:*:* Versions 6.9 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc2:*:*:*:*:*:* Versions 6.9 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc3:*:*:*:*:*:* Versions 6.9 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc4:*:*:*:*:*:* Versions 6.9 rc4 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.313, 5.4.275, 5.10.216, 5.15.157, 6.1.88, 6.6.29, 6.8.8, 6.9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-26994
- 2026-10-03 Alias added: GHSA-x632-g56x-qcm8
References
Patch 8
- https://git.kernel.org/stable/c/756c5cb7c09e537b87b5d3acafcb101b2ccf394f
- https://git.kernel.org/stable/c/8f6b62125befe1675446923e4171eac2c012959c
- https://git.kernel.org/stable/c/6401038acfa24cba9c28cce410b7505efadd0222
- https://git.kernel.org/stable/c/0d130158db29f5e0b3893154908cf618896450a8
- https://git.kernel.org/stable/c/89af25bd4b4bf6a71295f07e07a8ae7dc03c6595
- https://git.kernel.org/stable/c/8defb1d22ba0395b81feb963b96e252b097ba76f
- https://git.kernel.org/stable/c/0efb15c14c493263cb3a5f65f5ddfd4603d19a76
- https://git.kernel.org/stable/c/c8d2f34ea96ea3bce6ba2535f867f0d4ee3b22e1
Advisory 5
- https://lists.debian.org/debian-lts-announce/2024/06/msg00017.html
- https://lists.debian.org/debian-lts-announce/2024/06/msg00020.html
- https://lists.fedoraproject.org/archives/list/[email protected]/message/4EZ6PJW7VOZ224TD7N4JZNU6KV32ZJ53/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/DAMSOZXJEPUOXW33WZYWCVAY7Z5S7OOY/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/GCBZZEC7L7KTWWAS2NLJK6SO3IZIL4WW/
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-26994 · CVE Program
- CVE-2024-26994 · NVD
- FIRST EPSS
- GHSA-x632-g56x-qcm8 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-26994 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences