net/rds: fix WARNING in rds_conn_connect_if_down
Priority LOW 34Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: net/rds: fix WARNING in rds_conn_connect_if_down If connection isn't established yet, get_mr() will fail, trigger connection after get_mr().
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00312 24th percentileScored 2026-11-07
Fix Partial Linux (Linux): 3.19, 4.2, 4.5 +9Red Hat: 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.18.85 to before 3.19; 4.1.48 to before 4.2; 4.4.103 to before 4.5; 4.9.66 to before 4.10 | 3.19, 4.2, 4.5, 4.10 | Patch available | CNA |
| Linux | Linux | 4.11 and later | 4.19.310, 5.4.272, 5.10.213, 5.15.152, 6.1.82, 6.6.22, 6.7.10, 6.8 | Patch available | CNA |
- Linux VendorLinux Affected 3.18.85 to before 3.19; 4.1.48 to before 4.2; 4.4.103 to before 4.5; 4.9.66 to before 4.10 Fixed in 3.19, 4.2, 4.5, 4.10 Patch available CNA
- Linux VendorLinux Affected 4.11 and later Fixed in 4.19.310, 5.4.272, 5.10.213, 5.15.152, 6.1.82, 6.6.22, 6.7.10, 6.8 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.18.85 to before 3.19; 4.1.48 to before 4.2; 4.4.103 to before 4.5; 4.9.66 to before 4.10; 4.11 to before 4.19.310; 4.20 to before 5.4.272; 5.5 to before 5.10.213; 5.11 to before 5.15.152; 5.16 to before 6.1.82; 6.2 to before 6.6.22; 6.7 to before 6.7.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:-:*:*:*:*:*:* | 6.8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* | 6.8 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* | 6.8 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* | 6.8 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* | 6.8 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* | 6.8 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc6:*:*:*:*:*:* | 6.8 rc6 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.18.85 to before 3.19; 4.1.48 to before 4.2; 4.4.103 to before 4.5; 4.9.66 to before 4.10; 4.11 to before 4.19.310; 4.20 to before 5.4.272; 5.5 to before 5.10.213; 5.11 to before 5.15.152; 5.16 to before 6.1.82; 6.2 to before 6.6.22; 6.7 to before 6.7.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:-:*:*:*:*:*:* Versions 6.8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* Versions 6.8 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* Versions 6.8 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* Versions 6.8 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* Versions 6.8 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* Versions 6.8 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc6:*:*:*:*:*:* Versions 6.8 rc6 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 3.19, 4.2, 4.5, 4.10
- Fix · CNA Linux (Linux) Fixed in 4.19.310, 5.4.272, 5.10.213, 5.15.152, 6.1.82, 6.6.22, 6.7.10, 6.8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
Not affected: 2 products
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27024
- 2026-10-03 Alias added: GHSA-3cff-7cgm-mf7g
References
Patch 8
- https://git.kernel.org/stable/c/786854141057751bc08eb26f1b02e97c1631c8f4
- https://git.kernel.org/stable/c/997efea2bf3a4adb96c306b9ad6a91442237bf5b
- https://git.kernel.org/stable/c/9dfc15a10dfd44f8ff7f27488651cb5be6af83c2
- https://git.kernel.org/stable/c/b562ebe21ed9adcf42242797dd6cb75beef12bf0
- https://git.kernel.org/stable/c/998fd719e6d6468b930ac0c44552ea9ff8b07b80
- https://git.kernel.org/stable/c/2b505d05280739ce31d5708da840f42df827cb85
- https://git.kernel.org/stable/c/907761307469adecb02461a14120e9a1812a5fb1
- https://git.kernel.org/stable/c/c055fc00c07be1f0df7375ab0036cebd1106ed38
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-27024 · CVE Program
- CVE-2024-27024 · NVD
- FIRST EPSS
- GHSA-3cff-7cgm-mf7g · GitHub Advisory Database · CC BY 4.0
- CVE-2024-27024 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences