media: go7007: fix a memleak in go7007_load_encoder
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: media: go7007: fix a memleak in go7007_load_encoder In go7007_load_encoder, bounce(i.e. go->boot_fw), is allocated without a deallocation thereafter. After the following call chain: saa7134_go7007_init |-> go7007_boot_encoder |-> go7007_load_encoder |-> kfree(go) go is freed and thus bounce is leaked.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.10 and later | 4.19.311, 5.4.273, 5.10.214, 5.15.153, 6.1.83, 6.6.23, 6.7.11, 6.8.2, 6.9 | Patch available | CNA |
- Linux VendorLinux Affected 3.10 and later Fixed in 4.19.311, 5.4.273, 5.10.214, 5.15.153, 6.1.83, 6.6.23, 6.7.11, 6.8.2, 6.9 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 3.10 to before 4.19.311; 4.20 to before 5.4.273; 5.5 to before 5.10.214; 5.11 to before 5.15.153; 5.16 to before 6.1.83; 6.2 to before 6.6.23; 6.7 to before 6.7.11; 6.8 to before 6.8.2 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 3.10 to before 4.19.311; 4.20 to before 5.4.273; 5.5 to before 5.10.214; 5.11 to before 5.15.153; 5.16 to before 6.1.83; 6.2 to before 6.6.23; 6.7 to before 6.7.11; 6.8 to before 6.8.2 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.311, 5.4.273, 5.10.214, 5.15.153, 6.1.83, 6.6.23, 6.7.11, 6.8.2, 6.9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27074
- 2026-10-03 Alias added: GHSA-m4vr-jmc8-6xrj
References
Patch 11
- https://git.kernel.org/stable/c/7f11dd3d165b178e738fe73dfeea513e383bedb5
- https://git.kernel.org/stable/c/291cda0b805fc0d6e90d201710311630c8667159
- https://git.kernel.org/stable/c/b49fe84c6cefcc1c2336d793b53442e716c95073
- https://git.kernel.org/stable/c/790fa2c04dfb9f095ec372bf17909424d6e864b3
- https://git.kernel.org/stable/c/e04d15c8bb3e111dd69f98894acd92d63e87aac3
- https://git.kernel.org/stable/c/f31c1cc37411f5f7bcb266133f9a7e1b4bdf2975
- https://git.kernel.org/stable/c/d43988a23c32588ccd0c74219637afb96cd78661
- https://git.kernel.org/stable/c/7405a0d4442792988e9ae834e7d84f9d163731a4
- https://git.kernel.org/stable/c/b9b683844b01d171a72b9c0419a2d760d946ee12
- https://lists.debian.org/debian-lts-announce/2024/06/msg00017.html
- https://lists.debian.org/debian-lts-announce/2024/06/msg00020.html
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-27074 · CVE Program
- CVE-2024-27074 · NVD
- FIRST EPSS
- GHSA-m4vr-jmc8-6xrj · GitHub Advisory Database · CC BY 4.0
- CVE-2024-27074 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences