SMTP smuggling in aiosmtpd
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-345.
Summary
aiosmtpd is a reimplementation of the Python stdlib smtpd.py based on asyncio. aiosmtpd is vulnerable to inbound SMTP smuggling. SMTP smuggling is a novel vulnerability based on not so novel interpretation differences of the SMTP protocol. By exploiting SMTP smuggling, an attacker may send smuggle/spoof e-mails with fake sender addresses, allowing advanced phishing attacks. This issue is also existed in other SMTP software like Postfix. With the right SMTP server constellation, an attacker can send spoofed e-mails to inbound/receiving aiosmtpd instances. This issue has been addressed in version 1.4.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| aio-libs | aiosmtpd | before 1.4.5 | 1.4.5 | Patch available | CNA |
| — | aiosmtpd (PyPI) | before 1.4.5 | 1.4.5 | Patch available | GHSA-pr2m-px7j-xg65 |
- aiosmtpd Vendoraio-libs Affected before 1.4.5 Fixed in 1.4.5 Patch available CNA
- aiosmtpd (PyPI) Vendor— Affected before 1.4.5 Fixed in 1.4.5 Patch available GHSA-pr2m-px7j-xg65
Remediation
- Fix · CNA aiosmtpd (aio-libs) Fixed in 1.4.5
- Fix · GHSA-pr2m-px7j-xg65 aiosmtpd (PyPI) Fixed in 1.4.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27305
- 2026-10-03 Alias added: GHSA-pr2m-px7j-xg65
References
Advisory 2
Sources
- CVE-2024-27305 · CVE Program
- CVE-2024-27305 · NVD
- FIRST EPSS
- GHSA-pr2m-px7j-xg65 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-27305 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences