An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. An attacker can construct a malformed certificate containing an extremely large prime to cause a denial of service (CPU consumption for an isPrime primality check). NOTE: this issue was introduced when attempting to fix CVE-2023-27560.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpseclib/phpseclib (Packagist) | 0.1.1 to before 1.0.23 | 1.0.23 | Patch available | GHSA-2528-jw5q-ww88 |
| — | phpseclib/phpseclib (Packagist) | 2.0.0 to before 2.0.47 | 2.0.47 | Patch available | GHSA-2528-jw5q-ww88 |
| — | phpseclib/phpseclib (Packagist) | 3.0.0 to before 3.0.36 | 3.0.36 | Patch available | GHSA-2528-jw5q-ww88 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpseclib/phpseclib (Packagist) Vendor— Affected 0.1.1 to before 1.0.23 Fixed in 1.0.23 Patch available GHSA-2528-jw5q-ww88
- phpseclib/phpseclib (Packagist) Vendor— Affected 2.0.0 to before 2.0.47 Fixed in 2.0.47 Patch available GHSA-2528-jw5q-ww88
- phpseclib/phpseclib (Packagist) Vendor— Affected 3.0.0 to before 3.0.36 Fixed in 3.0.36 Patch available GHSA-2528-jw5q-ww88
Remediation
- Fix · GHSA-2528-jw5q-ww88 phpseclib/phpseclib (Packagist) Fixed in 1.0.23 Advisory →
- Fix · GHSA-2528-jw5q-ww88 phpseclib/phpseclib (Packagist) Fixed in 2.0.47 Advisory →
- Fix · GHSA-2528-jw5q-ww88 phpseclib/phpseclib (Packagist) Fixed in 3.0.36 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27354
- 2026-10-03 Alias added: GHSA-2528-jw5q-ww88
References
Advisory 4
Other 7
- https://github.com/phpseclib/phpseclib/blob/master/phpseclib/Math/PrimeField.php#L49
- https://github.com/phpseclib/phpseclib/security/advisories/GHSA-2528-jw5q-ww88
- https://github.com/phpseclib/phpseclib/commit/2870c8fab3f132d2ed40a66c97a36fe5ab625698
- https://github.com/phpseclib/phpseclib/commit/ad5dbdf2129f5e0fb644637770b7f33de8ca8575
- https://github.com/phpseclib/phpseclib/commit/c55b75199ec8d12cec6eadf6da99da4a3712fe56
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpseclib/phpseclib/CVE-2024-27354.yaml
- https://github.com/phpseclib/phpseclib
Sources
- CVE-2024-27354 · CVE Program
- CVE-2024-27354 · NVD
- FIRST EPSS
- GHSA-2528-jw5q-ww88 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-27354 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences