Read the docs
TI-2024-18192 Aliases CVE-2024-27355GHSA-f2qx-66wf-wvvx

An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before…

Priority MEDIUM 40CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

An issue was discovered in phpseclib 1.x before 1.0.23, 2.x before 2.0.47, and 3.x before 3.0.36. When processing the ASN.1 object identifier of a certificate, a sub identifier may be provided that leads to a denial of service (CPU consumption for decodeOID).

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00569 47th percentileScored 2026-11-07
Fix Fixed phpseclib/phpseclib (Packagist): 2.0.47, 3.0.36, 1.0.23

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpseclib/phpseclib (Packagist)2.0.0 to before 2.0.472.0.47Patch availableGHSA-f2qx-66wf-wvvx
—phpseclib/phpseclib (Packagist)3.0.0 to before 3.0.363.0.36Patch availableGHSA-f2qx-66wf-wvvx
—phpseclib/phpseclib (Packagist)0.1.1 to before 1.0.231.0.23Patch availableGHSA-f2qx-66wf-wvvx
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpseclib/phpseclib (Packagist) Vendor— Affected 2.0.0 to before 2.0.47 Fixed in 2.0.47 Patch available GHSA-f2qx-66wf-wvvx
  • phpseclib/phpseclib (Packagist) Vendor— Affected 3.0.0 to before 3.0.36 Fixed in 3.0.36 Patch available GHSA-f2qx-66wf-wvvx
  • phpseclib/phpseclib (Packagist) Vendor— Affected 0.1.1 to before 1.0.23 Fixed in 1.0.23 Patch available GHSA-f2qx-66wf-wvvx

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:phpseclib:phpseclib:*:*:*:*:*:*:*:*1.0.0 to before 1.0.23; 2.0.0 to before 2.0.47; 3.0.0 to before 3.0.36Vulnerablephpseclib
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:a:phpseclib:phpseclib:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.0.23; 2.0.0 to before 2.0.47; 3.0.0 to before 3.0.36 Vulnerable ·phpseclib
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-f2qx-66wf-wvvx phpseclib/phpseclib (Packagist) Fixed in 2.0.47 Advisory →
  • Fix · GHSA-f2qx-66wf-wvvx phpseclib/phpseclib (Packagist) Fixed in 3.0.36 Advisory →
  • Fix · GHSA-f2qx-66wf-wvvx phpseclib/phpseclib (Packagist) Fixed in 1.0.23 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-27355
  2. 2026-10-03 Alias added: GHSA-f2qx-66wf-wvvx

References

Sources