net: gtp: Fix Use-After-Free in gtp_dellink
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
In the Linux kernel, the following vulnerability has been resolved: net: gtp: Fix Use-After-Free in gtp_dellink Since call_rcu, which is called in the hlist_for_each_entry_rcu traversal of gtp_dellink, is not part of the RCU read critical section, it is possible that the RCU grace period will pass during the traversal and the key will be free. To prevent this, it should be changed to hlist_for_each_entry_safe.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19.93 to before 4.19.313; 5.4.8 to before 5.4.275; 4.14.162 to before 4.15 | 4.19.313, 5.4.275, 4.15 | Patch available | CNA |
| Linux | Linux | 5.5 and later | 4.19.313, 5.4.275, 5.10.216, 5.15.158, 6.1.90, 6.6.30, 6.8.9, 6.9 | Patch available | CNA |
- Linux VendorLinux Affected 4.19.93 to before 4.19.313; 5.4.8 to before 5.4.275; 4.14.162 to before 4.15 Fixed in 4.19.313, 5.4.275, 4.15 Patch available CNA
- Linux VendorLinux Affected 5.5 and later Fixed in 4.19.313, 5.4.275, 5.10.216, 5.15.158, 6.1.90, 6.6.30, 6.8.9, 6.9 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.14.162 to before 4.15; 4.19.93 to before 4.19.313; 5.4.8 to before 5.4.275; 5.5 to before 5.10.216; 5.11 to before 5.15.158; 5.16 to before 6.1.90; 6.2 to before 6.6.30; 6.7 to before 6.8.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc1:*:*:*:*:*:* | 6.9 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc2:*:*:*:*:*:* | 6.9 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc3:*:*:*:*:*:* | 6.9 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc4:*:*:*:*:*:* | 6.9 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc5:*:*:*:*:*:* | 6.9 rc5 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.14.162 to before 4.15; 4.19.93 to before 4.19.313; 5.4.8 to before 5.4.275; 5.5 to before 5.10.216; 5.11 to before 5.15.158; 5.16 to before 6.1.90; 6.2 to before 6.6.30; 6.7 to before 6.8.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc1:*:*:*:*:*:* Versions 6.9 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc2:*:*:*:*:*:* Versions 6.9 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc3:*:*:*:*:*:* Versions 6.9 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc4:*:*:*:*:*:* Versions 6.9 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc5:*:*:*:*:*:* Versions 6.9 rc5 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.313, 5.4.275, 4.15
- Fix · CNA Linux (Linux) Fixed in 4.19.313, 5.4.275, 5.10.216, 5.15.158, 6.1.90, 6.6.30, 6.8.9, 6.9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27396
- 2026-10-03 Alias added: GHSA-mvq3-v998-w43f
References
Patch 8
- https://git.kernel.org/stable/c/07b20d0a3dc13fb1adff10b60021a4924498da58
- https://git.kernel.org/stable/c/718df1bc226c383dd803397d7f5d95557eb81ac7
- https://git.kernel.org/stable/c/0caff3e6390f840666b8dc1ecebf985c2ef3f1dd
- https://git.kernel.org/stable/c/2e74b3fd6bf542349758f283676dff3660327c07
- https://git.kernel.org/stable/c/25a1c2d4b1fcf938356a9688a96a6456abd44b29
- https://git.kernel.org/stable/c/2aacd4de45477582993f8a8abb9505a06426bfb6
- https://git.kernel.org/stable/c/cd957d1716ec979d8f5bf38fc659aeb9fdaa2474
- https://git.kernel.org/stable/c/f2a904107ee2b647bb7794a1a82b67740d7c8a64
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-27396 · CVE Program
- CVE-2024-27396 · NVD
- FIRST EPSS
- GHSA-mvq3-v998-w43f · GitHub Advisory Database · CC BY 4.0
- CVE-2024-27396 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences