firewire: nosy: ensure user_length is taken into account when fetching packet contents
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: firewire: nosy: ensure user_length is taken into account when fetching packet contents Ensure that packet_buffer_get respects the user_length provided. If the length of the head packet exceeds the user_length, packet_buffer_get will now return 0 to signify to the user that no data were read and a larger buffer size is required. Helps prevent user space overflows.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.36 and later | 4.19.314, 5.4.276, 5.10.217, 5.15.159, 6.1.91, 6.6.31, 6.8.10, 6.9 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.36 and later Fixed in 4.19.314, 5.4.276, 5.10.217, 5.15.159, 6.1.91, 6.6.31, 6.8.10, 6.9 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 2.6.36 to before 4.19.314; 4.20 to before 5.4.276; 5.5 to before 5.10.217; 5.11 to before 5.15.159; 5.16 to before 6.1.91; 6.2 to before 6.6.31; 6.7 to before 6.8.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc1:*:*:*:*:*:* | 6.9 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc2:*:*:*:*:*:* | 6.9 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc3:*:*:*:*:*:* | 6.9 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc4:*:*:*:*:*:* | 6.9 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc5:*:*:*:*:*:* | 6.9 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc6:*:*:*:*:*:* | 6.9 rc6 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 2.6.36 to before 4.19.314; 4.20 to before 5.4.276; 5.5 to before 5.10.217; 5.11 to before 5.15.159; 5.16 to before 6.1.91; 6.2 to before 6.6.31; 6.7 to before 6.8.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc1:*:*:*:*:*:* Versions 6.9 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc2:*:*:*:*:*:* Versions 6.9 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc3:*:*:*:*:*:* Versions 6.9 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc4:*:*:*:*:*:* Versions 6.9 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc5:*:*:*:*:*:* Versions 6.9 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc6:*:*:*:*:*:* Versions 6.9 rc6 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.314, 5.4.276, 5.10.217, 5.15.159, 6.1.91, 6.6.31, 6.8.10, 6.9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27401
- 2026-10-03 Alias added: GHSA-wmmp-mchh-75gf
References
Patch 8
- https://git.kernel.org/stable/c/67f34f093c0f7bf33f5b4ae64d3d695a3b978285
- https://git.kernel.org/stable/c/7b8c7bd2296e95b38a6ff346242356a2e7190239
- https://git.kernel.org/stable/c/cca330c59c54207567a648357835f59df9a286bb
- https://git.kernel.org/stable/c/79f988d3ffc1aa778fc5181bdfab312e57956c6b
- https://git.kernel.org/stable/c/4ee0941da10e8fdcdb34756b877efd3282594c1f
- https://git.kernel.org/stable/c/1fe60ee709436550f8cfbab01295936b868d5baa
- https://git.kernel.org/stable/c/539d51ac48bcfcfa1b3d4a85f8df92fa22c1d41c
- https://git.kernel.org/stable/c/38762a0763c10c24a4915feee722d7aa6e73eb98
Advisory 4
- https://lists.debian.org/debian-lts-announce/2024/06/msg00019.html
- https://lists.debian.org/debian-lts-announce/2024/06/msg00020.html
- https://lists.fedoraproject.org/archives/list/[email protected]/message/DW2MIOIMOFUSNLHLRYX23AFR36BMKD65/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/OTB4HWU2PTVW5NEYHHLOCXDKG3PYA534/
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-27401 · CVE Program
- CVE-2024-27401 · NVD
- FIRST EPSS
- GHSA-wmmp-mchh-75gf · GitHub Advisory Database · CC BY 4.0
- CVE-2024-27401 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences