power: supply: bq27xxx-i2c: Do not free non existing IRQ
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: power: supply: bq27xxx-i2c: Do not free non existing IRQ The bq27xxx i2c-client may not have an IRQ, in which case client->irq will be 0. bq27xxx_battery_i2c_probe() already has an if (client->irq) check wrapping the request_threaded_irq(). But bq27xxx_battery_i2c_remove() unconditionally calls free_irq(client->irq) leading to: [ 190.310742] ------------[ cut here ]------------ [ 190.310843] Trying to free already-free IRQ 0 [ 190.310861] WARNING: CPU: 2 PID: 1304 at kernel/irq/manage.c:1893 free_irq+0x1b8/0x310 Followed by a backtrace when unbinding the driver. Add an if (client->irq) to bq27xxx_battery_i2c_remove() mirroring probe() to fix this.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19.284 to before 4.19.309; 5.4.244 to before 5.4.271; 5.10.181 to before 5.10.212; 5.15.114 to before 5.15.151; 6.1.31 to before 6.1.81; 4.14.316 to before 4.15; 6.3.5 to before 6.4 | 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 4.15, 6.4 | Patch available | CNA |
| Linux | Linux | 6.4 and later | 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8 | Patch available | CNA |
- Linux VendorLinux Affected 4.19.284 to before 4.19.309; 5.4.244 to before 5.4.271; 5.10.181 to before 5.10.212; 5.15.114 to before 5.15.151; 6.1.31 to before 6.1.81; 4.14.316 to before 4.15; 6.3.5 to before 6.4 Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 4.15, 6.4 Patch available CNA
- Linux VendorLinux Affected 6.4 and later Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8 Patch available CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.14.316 to before 4.15; 4.19.284 to before 4.19.309; 5.4.244 to before 5.4.271; 5.10.181 to before 5.10.212; 5.15.114 to before 5.15.151; 6.1.31 to before 6.1.81; 6.3.5 to before 6.4; 6.4.1 to before 6.6.21; 6.7 to before 6.7.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:-:*:*:*:*:*:* | 6.4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc4:*:*:*:*:*:* | 6.4 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc5:*:*:*:*:*:* | 6.4 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc6:*:*:*:*:*:* | 6.4 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc7:*:*:*:*:*:* | 6.4 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* | 6.8 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* | 6.8 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* | 6.8 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* | 6.8 rc4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.14.316 to before 4.15; 4.19.284 to before 4.19.309; 5.4.244 to before 5.4.271; 5.10.181 to before 5.10.212; 5.15.114 to before 5.15.151; 6.1.31 to before 6.1.81; 6.3.5 to before 6.4; 6.4.1 to before 6.6.21; 6.7 to before 6.7.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:-:*:*:*:*:*:* Versions 6.4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc4:*:*:*:*:*:* Versions 6.4 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc5:*:*:*:*:*:* Versions 6.4 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc6:*:*:*:*:*:* Versions 6.4 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc7:*:*:*:*:*:* Versions 6.4 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* Versions 6.8 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* Versions 6.8 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* Versions 6.8 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* Versions 6.8 rc4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 4.15, 6.4
- Fix · CNA Linux (Linux) Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27412
- 2026-10-03 Alias added: GHSA-8qjm-4vw9-3w5g
References
Patch 8
- https://git.kernel.org/stable/c/d4d813c0a14d6bf52d810a55db06a2e7e3d98eaa
- https://git.kernel.org/stable/c/7394abc8926adee6a817bab10797e0adc898af77
- https://git.kernel.org/stable/c/d7acc4a569f5f4513120c85ea2b9f04909b7490f
- https://git.kernel.org/stable/c/e601ae81910ce6a3797876e190a2d8ef6cf828bc
- https://git.kernel.org/stable/c/cefe18e9ec84f8fe3e198ccebb815cc996eb9797
- https://git.kernel.org/stable/c/fbca8bae1ba79d443a58781b45e92a73a24ac8f8
- https://git.kernel.org/stable/c/083686474e7c97b0f8b66df37fcb64e432e8b771
- https://git.kernel.org/stable/c/2df70149e73e79783bcbc7db4fa51ecef0e2022c
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-27412 · CVE Program
- CVE-2024-27412 · NVD
- FIRST EPSS
- GHSA-8qjm-4vw9-3w5g · GitHub Advisory Database · CC BY 4.0
- CVE-2024-27412 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences