Read the docs
TI-2024-18248 Aliases CVE-2024-27413GHSA-cv2p-mqwj-vfxc

efi/capsule-loader: fix incorrect allocation size

Priority LOW 24Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 3 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.

Summary

In the Linux kernel, the following vulnerability has been resolved: efi/capsule-loader: fix incorrect allocation size gcc-14 notices that the allocation with sizeof(void) on 32-bit architectures is not enough for a 64-bit phys_addr_t: drivers/firmware/efi/capsule-loader.c: In function 'efi_capsule_open': drivers/firmware/efi/capsule-loader.c:295:24: error: allocation of insufficient size '4' for type 'phys_addr_t' {aka 'long long unsigned int'} with size '8' [-Werror=alloc-size] 295 | cap_info->phys = kzalloc(sizeof(void *), GFP_KERNEL); | ^ Use the correct type instead here.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00246 15th percentileScored 2026-11-07
Fix Partial Linux (Linux): 4.15, 4.19.309, 5.4.271 +6Red Hat: 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux4.14.13 to before 4.154.15Patch availableCNA
LinuxLinux4.15 and later4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8Patch availableCNA
  • Linux VendorLinux Affected 4.14.13 to before 4.15 Fixed in 4.15 Patch available CNA
  • Linux VendorLinux Affected 4.15 and later Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8 Patch available CNA

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*4.14.13 to before 4.15; 4.15.1 to before 4.19.309; 4.20 to before 5.4.271; 5.5 to before 5.10.212; 5.11 to before 5.15.151; 5.16 to before 6.1.81; 6.2 to before 6.6.21; 6.7 to before 6.7.9VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.15:-:*:*:*:*:*:*4.15VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.15:rc7:*:*:*:*:*:*4.15 rc7VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.15:rc8:*:*:*:*:*:*4.15 rc8VulnerableLinux
cpe:2.3:o:linux:linux_kernel:4.15:rc9:*:*:*:*:*:*4.15 rc9VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:*6.8 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:*6.8 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:*6.8 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:*6.8 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:*6.8 rc5VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.14.13 to before 4.15; 4.15.1 to before 4.19.309; 4.20 to before 5.4.271; 5.5 to before 5.10.212; 5.11 to before 5.15.151; 5.16 to before 6.1.81; 6.2 to before 6.6.21; 6.7 to before 6.7.9 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.15:-:*:*:*:*:*:* Versions 4.15 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.15:rc7:*:*:*:*:*:* Versions 4.15 rc7 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.15:rc8:*:*:*:*:*:* Versions 4.15 rc8 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:4.15:rc9:*:*:*:*:*:* Versions 4.15 rc9 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* Versions 6.8 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* Versions 6.8 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* Versions 6.8 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* Versions 6.8 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* Versions 6.8 rc5 Vulnerable ·Linux
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:6.8:rc6:*:*:*:*:*:*6.8 rc6VulnerableLinux
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:o:linux:linux_kernel:6.8:rc6:*:*:*:*:*:* Versions 6.8 rc6 Vulnerable ·Linux
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · CNA Linux (Linux) Fixed in 4.15
  • Fix · CNA Linux (Linux) Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 8AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux 9AffectedNo fix planned: Will not fix
Not affected: 1 product
  • Red Hat Enterprise Linux 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-27413
  2. 2026-10-03 Alias added: GHSA-cv2p-mqwj-vfxc

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources