Bluetooth: hci_event: Fix handling of HCI_EV_IO_CAPA_REQUEST
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: hci_event: Fix handling of HCI_EV_IO_CAPA_REQUEST If we received HCI_EV_IO_CAPA_REQUEST while HCI_OP_READ_REMOTE_EXT_FEATURES is yet to be responded assume the remote does support SSP since otherwise this event shouldn't be generated.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.19.297 to before 4.19.309; 5.4.259 to before 5.4.271; 5.10.199 to before 5.10.212; 5.15.137 to before 5.15.151; 6.1.60 to before 6.1.81; 4.14.328 to before 4.15; 6.5.9 to before 6.6 | 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 4.15, 6.6 | Patch available | CNA |
| Linux | Linux | 6.6 and later | 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8 | Patch available | CNA |
- Linux VendorLinux Affected 4.19.297 to before 4.19.309; 5.4.259 to before 5.4.271; 5.10.199 to before 5.10.212; 5.15.137 to before 5.15.151; 6.1.60 to before 6.1.81; 4.14.328 to before 4.15; 6.5.9 to before 6.6 Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 4.15, 6.6 Patch available CNA
- Linux VendorLinux Affected 6.6 and later Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.14.328 to before 4.15; 4.19.297 to before 4.19.309; 5.4.259 to before 5.4.271; 5.10.199 to before 5.10.212; 5.15.137 to before 5.15.151; 6.1.60 to before 6.1.81; 6.5.9 to before 6.6; 6.6.1 to before 6.6.21; 6.7 to before 6.7.9 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.6:-:*:*:*:*:*:* | 6.6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.6:rc7:*:*:*:*:*:* | 6.6 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* | 6.8 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* | 6.8 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* | 6.8 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* | 6.8 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* | 6.8 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc6:*:*:*:*:*:* | 6.8 rc6 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.14.328 to before 4.15; 4.19.297 to before 4.19.309; 5.4.259 to before 5.4.271; 5.10.199 to before 5.10.212; 5.15.137 to before 5.15.151; 6.1.60 to before 6.1.81; 6.5.9 to before 6.6; 6.6.1 to before 6.6.21; 6.7 to before 6.7.9 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.6:-:*:*:*:*:*:* Versions 6.6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.6:rc7:*:*:*:*:*:* Versions 6.6 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* Versions 6.8 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* Versions 6.8 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* Versions 6.8 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* Versions 6.8 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* Versions 6.8 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc6:*:*:*:*:*:* Versions 6.8 rc6 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 4.15, 6.6
- Fix · CNA Linux (Linux) Fixed in 4.19.309, 5.4.271, 5.10.212, 5.15.151, 6.1.81, 6.6.21, 6.7.9, 6.8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
Not affected: 2 products
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27416
- 2026-10-03 Alias added: GHSA-qqp6-rvp4-537p
References
Patch 8
- https://git.kernel.org/stable/c/afec8f772296dd8e5a2a6f83bbf99db1b9ca877f
- https://git.kernel.org/stable/c/79820a7e1e057120c49be07cbe10643d0706b259
- https://git.kernel.org/stable/c/df193568d61234c81de7ed4d540c01975de60277
- https://git.kernel.org/stable/c/c3df637266df29edee85e94cab5fd7041e5753ba
- https://git.kernel.org/stable/c/30a5e812f78e3d1cced90e1ed750bf027599205f
- https://git.kernel.org/stable/c/fba268ac36ab19f9763ff90d276cde0ce6cd5f31
- https://git.kernel.org/stable/c/8e2758cc25891d2b76717aaf89b40ed215de188c
- https://git.kernel.org/stable/c/7e74aa53a68bf60f6019bd5d9a9a1406ec4d4865
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-27416 · CVE Program
- CVE-2024-27416 · NVD
- FIRST EPSS
- GHSA-qqp6-rvp4-537p · GitHub Advisory Database · CC BY 4.0
- CVE-2024-27416 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences