Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
Amazon AWS Amplify CLI before 12.10.1 incorrectly configures the role trust policy of IAM roles associated with Amplify projects. When the Authentication component is removed from an Amplify project, a Condition property is removed but "Effect":"Allow" remains present, and consequently sts:AssumeRoleWithWebIdentity would be available to threat actors with no conditions. Thus, if Amplify CLI had been used to remove the Authentication component from a project built between August 2019 and January 2024, an "assume role" may have occurred, and may have been leveraged to obtain unauthorized access to an organization's AWS resources. NOTE: the problem could only occur if an authorized AWS user removed an Authentication component. (The vulnerability did not give a threat actor the ability to remove an Authentication component.) However, in realistic situations, an authorized AWS user may have removed an Authentication component, e.g., if the objective were to stop using built-in Cognito resources, or move to a completely different identity provider.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | @aws-amplify/cli (npm) | before 12.10.1 | 12.10.1 | Patch available | GHSA-846g-p7hm-f54r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- @aws-amplify/cli (npm) Vendor— Affected before 12.10.1 Fixed in 12.10.1 Patch available GHSA-846g-p7hm-f54r
Remediation
- Fix · GHSA-846g-p7hm-f54r @aws-amplify/cli (npm) Fixed in 12.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28056
- 2026-10-03 Alias added: GHSA-846g-p7hm-f54r
References
Advisory 2
Other 5
- https://github.com/aws-amplify/amplify-cli/releases/tag/v12.10.1
- https://github.com/aws-amplify/amplify-cli/blob/8ad57bf99a404f3c92547c8a175458016f682fac/packages/amplify-provider-awscloudformation/resources/update-idp-roles-cfn.json
- https://aws.amazon.com/security/security-bulletins/AWS-2024-003
- https://github.com/aws-amplify/amplify-cli
- https://securitylabs.datadoghq.com/articles/amplified-exposure-how-aws-flaws-made-amplify-iam-roles-vulnerable-to-takeover
Sources
- CVE-2024-28056 · CVE Program
- CVE-2024-28056 · NVD
- FIRST EPSS
- GHSA-846g-p7hm-f54r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences