Action Pack is missing security headers on non-HTML responses
Priority MEDIUM 43CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Action Pack is a framework for handling and responding to web requests. Since 6.1.0, the application configurable Permissions-Policy is only served on responses with an HTML related Content-Type. This vulnerability is fixed in 6.1.7.8, 7.0.8.2, and 7.1.3.3.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00658 51st percentileScored 2026-11-07
Fix Partial rails (rails): 6.1.7.8, 7.0.8.4, 7.1.3.4 +1actionpack (RubyGems): 6.1.7.8, 7.0.8.4, 7.1.3.4 +1Red Hat: 1 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Rails | rails | 6.1.0.0 to before 6.1.7.8; 7.0.0.0 to before 7.0.8.4; 7.1.0.0 to before 7.1.3.4; 7.2.0.beta1 to before 7.2.0.beta2 | 6.1.7.8, 7.0.8.4, 7.1.3.4, 7.2.0.beta2 | Patch available | CNA |
| — | actionpack (RubyGems) | 6.1.0 to before 6.1.7.8 | 6.1.7.8 | Patch available | GHSA-fwhr-88qx-h9g7 |
| — | actionpack (RubyGems) | 7.0.0 to before 7.0.8.4 | 7.0.8.4 | Patch available | GHSA-fwhr-88qx-h9g7 |
| — | actionpack (RubyGems) | 7.1.0 to before 7.1.3.4 | 7.1.3.4 | Patch available | GHSA-fwhr-88qx-h9g7 |
| — | actionpack (RubyGems) | 7.2.0.beta1 to before 7.2.0.beta2 | 7.2.0.beta2 | Patch available | GHSA-fwhr-88qx-h9g7 |
- rails VendorRails Affected 6.1.0.0 to before 6.1.7.8; 7.0.0.0 to before 7.0.8.4; 7.1.0.0 to before 7.1.3.4; 7.2.0.beta1 to before 7.2.0.beta2 Fixed in 6.1.7.8, 7.0.8.4, 7.1.3.4, 7.2.0.beta2 Patch available CNA
- actionpack (RubyGems) Vendor— Affected 6.1.0 to before 6.1.7.8 Fixed in 6.1.7.8 Patch available GHSA-fwhr-88qx-h9g7
- actionpack (RubyGems) Vendor— Affected 7.0.0 to before 7.0.8.4 Fixed in 7.0.8.4 Patch available GHSA-fwhr-88qx-h9g7
- actionpack (RubyGems) Vendor— Affected 7.1.0 to before 7.1.3.4 Fixed in 7.1.3.4 Patch available GHSA-fwhr-88qx-h9g7
- actionpack (RubyGems) Vendor— Affected 7.2.0.beta1 to before 7.2.0.beta2 Fixed in 7.2.0.beta2 Patch available GHSA-fwhr-88qx-h9g7
Remediation
- Fix · CNA rails (rails) Fixed in 6.1.7.8, 7.0.8.4, 7.1.3.4, 7.2.0.beta2
- Fix · GHSA-fwhr-88qx-h9g7 actionpack (RubyGems) Fixed in 6.1.7.8 Advisory →
- Fix · GHSA-fwhr-88qx-h9g7 actionpack (RubyGems) Fixed in 7.0.8.4 Advisory →
- Fix · GHSA-fwhr-88qx-h9g7 actionpack (RubyGems) Fixed in 7.1.3.4 Advisory →
- Fix · GHSA-fwhr-88qx-h9g7 actionpack (RubyGems) Fixed in 7.2.0.beta2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6 | Affected | No fix yet |
Not affected: 1 product
- Red Hat 3scale API Management Platform 2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28103
- 2026-10-03 Alias added: GHSA-fwhr-88qx-h9g7
- 2026-10-11 EPSS moved to the 50th–90th percentile
References
Advisory 2
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2024-28103 · CVE Program
- CVE-2024-28103 · NVD
- FIRST EPSS
- GHSA-fwhr-88qx-h9g7 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-28103 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences