Cross-site scripting in Jenkins OWASP Dependency-Check Plugin
Priority LOW 33CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins OWASP Dependency-Check Plugin 5.4.5 and earlier does not escape vulnerability metadata from Dependency-Check reports, resulting in a stored cross-site scripting (XSS) vulnerability.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00693 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): 5.4.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins OWASP Dependency-Check Plugin | up to 5.4.5 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven) | before 5.4.6 | 5.4.6 | Patch available | GHSA-9pp4-mx6x-xh36 |
- Jenkins OWASP Dependency-Check Plugin VendorJenkins Affected up to 5.4.5 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven) Vendor— Affected before 5.4.6 Fixed in 5.4.6 Patch available GHSA-9pp4-mx6x-xh36
Remediation
- Fix · GHSA-9pp4-mx6x-xh36 org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven) Fixed in 5.4.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28153
- 2026-10-03 Alias added: GHSA-9pp4-mx6x-xh36
References
Advisory 3
More Jenkins Owasp Dependency-check vulnerabilities
- TI-2021-19466 XML external entity injection in Jenkins OWASP Dependency-Check Plugin CVSS 3.1HIGH 7.1
- TI-2017-14446 The custom Details view of the Static Analysis Utilities based OWASP Dependency-Check… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2024-28153 · CVE Program
- CVE-2024-28153 · NVD
- FIRST EPSS
- GHSA-9pp4-mx6x-xh36 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences