Read the docs
TI-2024-18795 Aliases CVE-2024-28236GHSA-pwx5-6wxg-px5h

Insecure Variable Substitution in Vela

Priority LOW 35CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. Vela pipelines can use variable substitution combined with insensitive fields like `parameters`, `image` and `entrypoint` to inject secrets into a plugin/image and — by using common substitution string manipulation — can bypass log masking and expose secrets without the use of the commands block. This unexpected behavior primarily impacts secrets restricted by the "no commands" option. This can lead to unintended use of the secret value, and increased risk of exposing the secret during image execution bypassing log masking. **To exploit this** the pipeline author must be supplying the secrets to a plugin that is designed in such a way that will print those parameters in logs. Plugin parameters are not designed for sensitive values and are often intentionally printed throughout execution for informational/debugging purposes. Parameters should therefore be treated as insensitive. While Vela provides secrets masking, secrets exposure is not entirely solved by the masking process. A docker image (plugin) can easily expose secrets if they are not handled properly, or altered in some way. There is a responsibility on the end-user to understand how values injected into a plugin are used. This is a risk that exists for many CICD systems (like GitHub Actions) that handle sensitive runtime variables. Rather, the greater risk is that users who restrict a secret to the "no commands" option and use image restriction can still have their secret value exposed via substitution tinkering, which turns the image and command restrictions into a false sense of security. This issue has been addressed in version 0.23.2. Users are advised to upgrade. Users unable to upgrade should not provide sensitive values to plugins that can potentially expose them, especially in `parameters` that are not intended to be used for sensitive values, ensure plugins (especially those that utilize shared secrets) follow best practices to avoid logging parameters that are expected to be sensitive, minimize secrets with `pull_request` events enabled, as this allows users to change pipeline configurations and pull in secrets to steps not typically part of the CI process, make use of the build approval setting, restricting builds from untrusted users, and limit use of shared secrets, as they are less restrictive to access by nature.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00716 54th percentileScored 2026-11-07
Fix Fixed worker (go-vela): 0.23.2github.com/go-vela/worker (Go): 0.23.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
go-velaworkerbefore 0.23.20.23.2Patch availableCNA
—github.com/go-vela/worker (Go)before 0.23.20.23.2Patch availableGHSA-pwx5-6wxg-px5h
  • worker Vendorgo-vela Affected before 0.23.2 Fixed in 0.23.2 Patch available CNA
  • github.com/go-vela/worker (Go) Vendor— Affected before 0.23.2 Fixed in 0.23.2 Patch available GHSA-pwx5-6wxg-px5h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:go-vela:worker:*:*:*:*:*:*:*:*before 0.23.2Vulnerablego-vela
  • cpe:2.3:a:go-vela:worker:*:*:*:*:*:*:*:* Versions before 0.23.2 Vulnerable ·go-vela

Remediation

  • Fix · CNA worker (go-vela) Fixed in 0.23.2
  • Fix · GHSA-pwx5-6wxg-px5h github.com/go-vela/worker (Go) Fixed in 0.23.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-28236
  2. 2026-10-03 Alias added: GHSA-pwx5-6wxg-px5h

References

Sources