Cross Site Scripting (XSS) vulnerability in SurveyJS Survey Creator v.1.9.132 and before…
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting (XSS) vulnerability in SurveyJS Survey Creator v.1.9.132 and before, allows attackers to execute arbitrary code and obtain sensitive information via the title parameter in form.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00508 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed survey-creator (npm): 1.9.133
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | survey-creator (npm) | before 1.9.133 | 1.9.133 | Patch available | GHSA-xgj4-2hrf-j4xg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- survey-creator (npm) Vendor— Affected before 1.9.133 Fixed in 1.9.133 Patch available GHSA-xgj4-2hrf-j4xg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:devsoftbaltic:survey-creator:*:*:*:*:*:*:*:* | up to 1.9.132 | Vulnerable | devsoftbaltic |
- cpe:2.3:a:devsoftbaltic:survey-creator:*:*:*:*:*:*:*:* Versions up to 1.9.132 Vulnerable ·devsoftbaltic
Remediation
- Fix · GHSA-xgj4-2hrf-j4xg survey-creator (npm) Fixed in 1.9.133 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28635
- 2026-10-03 Alias added: GHSA-xgj4-2hrf-j4xg
References
Sources
- CVE-2024-28635 · CVE Program
- CVE-2024-28635 · NVD
- FIRST EPSS
- GHSA-xgj4-2hrf-j4xg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences