Read the docs
TI-2024-18963 Aliases CVE-2024-28718GHSA-jx7x-9r98-h5xr

An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute…

Priority MEDIUM 51CWE-367Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

An issue in OpenStack magnum yoga-eom version allows a remote attacker to execute arbitrary code via the cert_manager.py. component.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01063 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed magnum (PyPI): 14.1.2, 17.0.2, 16.0.2 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—magnum (PyPI)before 14.1.214.1.2Patch availableGHSA-jx7x-9r98-h5xr
—magnum (PyPI)17.0.0.0rc1 to before 17.0.217.0.2Patch availableGHSA-jx7x-9r98-h5xr
—magnum (PyPI)16.0.0.0rc1 to before 16.0.216.0.2Patch availableGHSA-jx7x-9r98-h5xr
—magnum (PyPI)15.0.0.0rc1 to before 15.0.215.0.2Patch availableGHSA-jx7x-9r98-h5xr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • magnum (PyPI) Vendor— Affected before 14.1.2 Fixed in 14.1.2 Patch available GHSA-jx7x-9r98-h5xr
  • magnum (PyPI) Vendor— Affected 17.0.0.0rc1 to before 17.0.2 Fixed in 17.0.2 Patch available GHSA-jx7x-9r98-h5xr
  • magnum (PyPI) Vendor— Affected 16.0.0.0rc1 to before 16.0.2 Fixed in 16.0.2 Patch available GHSA-jx7x-9r98-h5xr
  • magnum (PyPI) Vendor— Affected 15.0.0.0rc1 to before 15.0.2 Fixed in 15.0.2 Patch available GHSA-jx7x-9r98-h5xr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:openstack:magnum:-:*:*:*:*:*:*:*not specified by NVDVulnerableOpenStack
  • cpe:2.3:a:openstack:magnum:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·OpenStack

Remediation

  • Fix · GHSA-jx7x-9r98-h5xr magnum (PyPI) Fixed in 14.1.2 Advisory →
  • Fix · GHSA-jx7x-9r98-h5xr magnum (PyPI) Fixed in 17.0.2 Advisory →
  • Fix · GHSA-jx7x-9r98-h5xr magnum (PyPI) Fixed in 16.0.2 Advisory →
  • Fix · GHSA-jx7x-9r98-h5xr magnum (PyPI) Fixed in 15.0.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-28718
  2. 2026-10-03 Alias added: GHSA-jx7x-9r98-h5xr

References

  • TI-2016-06305 OpenStack Magnum passes OpenStack credentials into the Heat templates creating its… CVSS 3.0CRITICAL 9.8

Sources