Read the docs
TI-2024-19061 Aliases CVE-2024-28862GHSA-x2h8-qmj4-g62f

ROTP 6.2.2 and 6.2.1 has 0666 permissions for the .rb files.

Priority LOW 24CWE-276Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

The Ruby One Time Password library (ROTP) is an open source library for generating and validating one time passwords. Affected versions had overly permissive default permissions. Users should patch to version 6.3.0. Users unable to patch may correct file permissions after installation.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00176 7th percentileScored 2026-11-07
Fix Fixed rotp (RubyGems): 6.3.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
mdprotp= 6.2.2; = 6.2.1—No fix listedCNA
—rotp (RubyGems)6.2.1 to before 6.3.06.3.0Patch availableGHSA-x2h8-qmj4-g62f
  • rotp Vendormdp Affected = 6.2.2; = 6.2.1 Fixed in — No fix listed CNA
  • rotp (RubyGems) Vendor— Affected 6.2.1 to before 6.3.0 Fixed in 6.3.0 Patch available GHSA-x2h8-qmj4-g62f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:rotp_project:rotp:*:*:*:*:*:ruby:*:*6.2.1 to before 6.3.0VulnerableRotp Project
  • cpe:2.3:a:rotp_project:rotp:*:*:*:*:*:ruby:*:* Versions 6.2.1 to before 6.3.0 Vulnerable ·Rotp Project

Remediation

  • Fix · GHSA-x2h8-qmj4-g62f rotp (RubyGems) Fixed in 6.3.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-28862
  2. 2026-10-03 Alias added: GHSA-x2h8-qmj4-g62f

References

Sources