Cross-site scripting in Dell PowerProtect DD
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Dell PowerProtect DD, versions prior to 8.0, LTS 7.13.1.0, LTS 7.10.1.30, LTS 7.7.5.40 contain a Stored Cross-Site Scripting Vulnerability. A remote high privileged attacker could potentially exploit this vulnerability, leading to the storage of malicious HTML or JavaScript codes in a trusted application data store. When a high privileged victim user accesses the data store through their browsers, the malicious code gets executed by the web browser in the context of the vulnerable web application. Exploitation may lead to information disclosure, session theft, or client-side request forgery
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerProtect DD | 7.0 – 7.13; N/A to before 2.7.7; N/A to before 5.16.0.0 | 2.7.7, 5.16.0.0 | Patch available | CNA |
- PowerProtect DD VendorDell Affected 7.0 – 7.13; N/A to before 2.7.7; N/A to before 5.16.0.0 Fixed in 2.7.7, 5.16.0.0 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:data_domain_operating_system:*:*:*:*:*:*:*:* | 7.0 – 7.13 | Vulnerable | Dell |
| cpe:2.3:h:dell:dd3300:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:dd6400:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:dd6900:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:dd9400:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:dd9410:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:dd9900:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:dd9910:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:data_domain_operating_system:*:*:*:*:*:*:*:* | before 5.16.0.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:dm5500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:data_domain_operating_system:*:*:*:*:*:*:*:* Versions 7.0 – 7.13 Vulnerable ·Dell
- cpe:2.3:h:dell:dd3300:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:dd6400:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:dd6900:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:dd9400:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:dd9410:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:dd9900:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:dd9910:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:data_domain_operating_system:*:*:*:*:*:*:*:* Versions before 5.16.0.0 Vulnerable ·Dell
- cpe:2.3:h:dell:dm5500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA PowerProtect DD (Dell) Fixed in 2.7.7, 5.16.0.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Dell PowerProtect DD — dell.com/support/kbdoc/en-us/000226148/dsa-2024-219-dell-te…
10 records Highest priority Priority MEDIUM 2 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2024-24667 OS command injection in Dell PowerProtect DDPriority MEDIUM 42
- TI-2024-19345 Out-of-bounds write in Dell PowerProtect DDPriority MEDIUM 41
- TI-2024-24665 Path traversal in Dell PowerProtect DDPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28973
- 2026-10-03 Alias added: GHSA-rjv4-w97f-h7vm
References
More Dell Data Domain Operating System vulnerabilities
- TI-2026-38564 Improper authentication in Dell PowerProtect Data Domain CVSS 3.1CRITICAL 9.8
- TI-2026-38562 Path traversal in Dell PowerProtect Data Domain CVSS 3.1CRITICAL 9.8
- TI-2025-24901 Authentication bypass by spoofing in Dell PowerProtect Data Domain Feature Release CVSS 3.1CRITICAL 9.8
- TI-2026-21302 Stack-based buffer overflow in Dell PowerProtect Data Domain CVSS 3.1CRITICAL 9.8
- TI-2024-24667 OS command injection in Dell PowerProtect DD CVSS 3.1HIGH 8.8
- TI-2026-21430 Missing authentication in Dell PowerProtect Data Domain CVSS 3.1HIGH 8.8
Sources
- CVE-2024-28973 · CVE Program
- CVE-2024-28973 · NVD
- FIRST EPSS
- GHSA-rjv4-w97f-h7vm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences