WordPress FlatPM plugin < 3.1.05 - Cross Site Scripting (XSS) vulnerability
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mehanoid.Pro FlatPM allows Stored XSS.This issue affects FlatPM: from n/a before 3.1.05.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00339 27th percentileScored 2026-11-07
Fix Fixed FlatPM (Mehanoid.pro): 3.1.05
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mehanoid.pro | FlatPM | before 3.1.05 | 3.1.05 | Patch available | CNA |
- FlatPM VendorMehanoid.pro Affected before 3.1.05 Fixed in 3.1.05 Patch available CNA
Remediation
- Fix · CNA FlatPM (Mehanoid.pro) Fixed in 3.1.05
Timeline
- 2026-10-02 Threatist record created from CVE-2024-29803
- 2026-10-03 Alias added: GHSA-8388-67wp-2gp9
References
Sources
- CVE-2024-29803 · CVE Program
- CVE-2024-29803 · NVD
- FIRST EPSS
- GHSA-8388-67wp-2gp9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences