Improper privilege management in Dell ECS
Priority LOW 29CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
Dell ECS, versions prior to 3.8.1, contain a privilege elevation vulnerability in user management. A remote high privileged attacker could potentially exploit this vulnerability, gaining access to unauthorized end points.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00328 26th percentileScored 2026-11-07
Fix Fixed ECS (Dell): 3.8.1.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ECS (Dell) Fixed in 3.8.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-30473
- 2026-10-03 Alias added: GHSA-95wh-v7qr-65p8
References
More Dell Elastic Cloud Storage vulnerabilities
- TI-2026-29362 Hard-coded credentials in Dell ECS CVSS 3.1CRITICAL 9.8
- TI-2017-05618 EMC Elastic Cloud Storage (ECS) before 3.1 is affected by an undocumented account… CVSS 3.1CRITICAL 9.8
- TI-2026-27313 CSV injection in Dell ECS CVSS 3.1CRITICAL 9.8
- TI-2026-17882 Dell ECS, versions 3.8.1.0 through 3.8.1.7, and Dell ObjectScale versions prior to… CVSS 3.1HIGH 8.8
- TI-2025-19424 Improper input validation in Dell ECS CVSS 3.1HIGH 8.8
- TI-2023-11182 Improper signature verification in Dell ECS CVSS 3.1HIGH 7.5
Sources
- CVE-2024-30473 · CVE Program
- CVE-2024-30473 · NVD
- FIRST EPSS
- GHSA-95wh-v7qr-65p8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences