Read the docs
TI-2024-20257 Aliases CVE-2024-30533GHSA-35p4-8325-mm2c

WordPress Layouts for Elementor plugin < 1.8 - Arbitrary File Upload vulnerability

Priority LOW 39CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.

Summary

Unrestricted Upload of File with Dangerous Type vulnerability in Techeshta Layouts for Elementor.This issue affects Layouts for Elementor: from n/a before 1.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00456 39th percentileScored 2026-11-07
Fix Fixed Layouts for Elementor (Techeshta): 1.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
TecheshtaLayouts for Elementorbefore 1.81.8Patch availableCNA
  • Layouts for Elementor VendorTecheshta Affected before 1.8 Fixed in 1.8 Patch available CNA

CPE names CISA-ADP · 1

CPEVersionsRoleVendor
cpe:2.3:a:techeshta:layouts_for_elementor:*:*:*:*:*:*:*:*——Techeshta
  • cpe:2.3:a:techeshta:layouts_for_elementor:*:*:*:*:*:*:*:* Versions — — ·Techeshta

Remediation

  • Fix · CNA Layouts for Elementor (Techeshta) Fixed in 1.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-30533
  2. 2026-10-03 Alias added: GHSA-35p4-8325-mm2c

References

  • TI-2026-06808 Missing authorization in Techeshta Layouts for WPBakery CVSS 3.1MEDIUM 6.5
  • TI-2024-25917 WordPress Post Layouts for Gutenberg plugin <= 1.2.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2026-05742 Cross-site scripting in Techeshta Timeline Blocks for Gutenberg CVSS 3.1MEDIUM 6.4
  • TI-2025-36025 WordPress Card Elements for WPBakery Plugin <= 1.0.8 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-28794 WordPress Card Elements for Elementor plugin <= 1.2.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-12773 Card Elements for Elementor <= 1.2.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Profile Card Widget CVSS 3.1MEDIUM 6.4

Sources