gin-vue-admin background arbitrary code coverage vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
gin-vue-admin is a backstage management system based on vue and gin, which separates the front and rear of the full stack. gin-vue-admin pseudoversion 0.0.0-20240407133540-7bc7c3051067, corresponding to version 2.6.1, has a code injection vulnerability in the backend. In the Plugin System -> Plugin Template feature, an attacker can perform directory traversal by manipulating the `plugName` parameter. They can create specific folders such as `api`, `config`, `global`, `model`, `router`, `service`, and `main.go` function within the specified traversal directory. Moreover, the Go files within these folders can have arbitrary code inserted based on a specific PoC parameter. The main reason for the existence of this vulnerability is the controllability of the PlugName field within the struct. Pseudoversion 0.0.0-20240409100909-b1b7427c6ea6, corresponding to commit b1b7427c6ea6c7a027fa188c6be557f3795e732b, contains a patch for the issue. As a workaround, one may manually use a filtering method available in the GitHub Security Advisory to rectify the directory traversal problem.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| flipped-aurora | gin-vue-admin | before 0.0.0-20240409100909-b1b7427c6ea6 | 0.0.0-20240409100909-b1b7427c6ea6 | Patch available | CNA |
| — | github.com/flipped-aurora/gin-vue-admin/server (Go) | before 0.0.0-20240409100909-b1b7427c6ea6 | 0.0.0-20240409100909-b1b7427c6ea6 | Patch available | GHSA-gv3w-m57p-3wc4 |
- gin-vue-admin Vendorflipped-aurora Affected before 0.0.0-20240409100909-b1b7427c6ea6 Fixed in 0.0.0-20240409100909-b1b7427c6ea6 Patch available CNA
- github.com/flipped-aurora/gin-vue-admin/server (Go) Vendor— Affected before 0.0.0-20240409100909-b1b7427c6ea6 Fixed in 0.0.0-20240409100909-b1b7427c6ea6 Patch available GHSA-gv3w-m57p-3wc4
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:flipped-aurora:gin-vue-admin:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:flipped-aurora:gin-vue-admin:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
- Fix · CNA gin-vue-admin (flipped-aurora) Fixed in 0.0.0-20240409100909-b1b7427c6ea6
- Fix · GHSA-gv3w-m57p-3wc4 github.com/flipped-aurora/gin-vue-admin/server (Go) Fixed in 0.0.0-20240409100909-b1b7427c6ea6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-31457
- 2026-10-03 Alias added: GHSA-gv3w-m57p-3wc4
References
Other 5
- https://github.com/flipped-aurora/gin-vue-admin/security/advisories/GHSA-gv3w-m57p-3wc4
- https://github.com/flipped-aurora/gin-vue-admin/commit/b1b7427c6ea6c7a027fa188c6be557f3795e732b
- https://pkg.go.dev/github.com/flipped-aurora/gin-vue-admin/server?tab=versions
- https://github.com/flipped-aurora/gin-vue-admin
- https://github.com/flipped-aurora/gin-vue-admin/blob/746af378990ebf3367f8bb3d4e9684936df152e7/server/api/v1/system/sys_auto_code.go:239
More flipped-aurora vulnerabilities
- TI-2022-18720 Gin-vue-admin arbitrary file upload vulnerability caused by path traversal CVSS 3.1CRITICAL 9.8
- TI-2022-18681 Gin-vue-admin vulnerable to Unrestricted Upload of File with Dangerous Type CVSS 3.1CRITICAL 9.8
- TI-2022-13903 Gin-vue-admin - Unrestricted File Upload CVSS 3.1CRITICAL 9.0
- TI-2022-13902 Gin-vue-admin - Unrestricted File Upload CVSS 3.1CRITICAL 9.0
- TI-2024-25212 SQL injection vulnerability in Gin-vue-admin CVSS 3.1HIGH 8.8
- TI-2022-08656 SQL Injection in github.com/flipped-aurora/gin-vue-admin CVSS 3.1HIGH 8.8
Sources
- CVE-2024-31457 · CVE Program
- CVE-2024-31457 · NVD
- FIRST EPSS
- GHSA-gv3w-m57p-3wc4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences