Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in…
Priority LOW 36CWE-416Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-416 and the CVSS impact.
Summary
Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00266 18th percentileScored 2026-11-07
Fix Fixed torch (PyPI): 2.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | torch (PyPI) | before 2.2.0 | 2.2.0 | Patch available | GHSA-pg7h-5qx3-wjr3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- torch (PyPI) Vendor— Affected before 2.2.0 Fixed in 2.2.0 Patch available GHSA-pg7h-5qx3-wjr3
Remediation
- Fix · GHSA-pg7h-5qx3-wjr3 torch (PyPI) Fixed in 2.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-31583
- 2026-10-03 Alias added: GHSA-pg7h-5qx3-wjr3
References
Advisory 2
More backstage Pytorch vulnerabilities
- TI-2024-32257 In PyTorch <=2.4.1, the RemoteModule has Deserialization RCE. CVSS 3.1CRITICAL 9.8
- TI-2025-35037 A Name Error occurs in pytorch v2.7.0 when a PyTorch model consists of torch.cummin and… CVSS 3.1HIGH 7.5
- TI-2025-35034 A syntax error in the component proxy_tensor.py of pytorch v2.7.0 allows attackers to cause a Denial of Service (DoS). CVSS 3.1HIGH 7.5
- TI-2025-35033 pytorch v2.8.0 was discovered to display unexpected behavior when the components… CVSS 3.1HIGH 7.5
- TI-2025-35032 An issue in the component torch.linalg.lu of pytorch v2.8.0 allows attackers to cause a… CVSS 3.1HIGH 7.5
- TI-2025-35038 A buffer overflow occurs in pytorch v2.7.0 when a PyTorch model consists of… CVSS 3.1HIGH 7.5
Sources
- CVE-2024-31583 · CVE Program
- CVE-2024-31583 · NVD
- FIRST EPSS
- GHSA-pg7h-5qx3-wjr3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences