Read the docs
TI-2024-20987 Aliases CVE-2024-31869GHSA-2522-mrjc-m688

Apache Airflow: Sensitive configuration for providers displayed when "non-sensitive-only" config used

Priority LOW 26CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Airflow versions 2.7.0 through 2.8.4 have a vulnerability that allows an authenticated user to see sensitive provider configuration via the "configuration" UI page when "non-sensitive-only" was set as "webserver.expose_config" configuration (The celery provider is the only community provider currently that has sensitive configurations). You should migrate to Airflow 2.9 or change your "expose_config" configuration to False as a workaround. This is similar, but different to CVE-2023-46288 https://github.com/advisories/GHSA-9qqg-mh7c-chfq which concerned API, not UI configuration page.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01058 64th percentileScored 2026-11-07
Fix Fixed apache-airflow (PyPI): 2.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Airflow2.7.0 – 2.8.4—No fix listedCNA
—apache-airflow (PyPI)2.7.0 to before 2.9.02.9.0Patch availableGHSA-2522-mrjc-m688
  • Apache Airflow VendorApache Affected 2.7.0 – 2.8.4 Fixed in — No fix listed CNA
  • apache-airflow (PyPI) Vendor— Affected 2.7.0 to before 2.9.0 Fixed in 2.9.0 Patch available GHSA-2522-mrjc-m688

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*2.7.0 to before 2.9.0VulnerableApache
  • cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.9.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-2522-mrjc-m688 apache-airflow (PyPI) Fixed in 2.9.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-31869
  2. 2026-10-03 Alias added: GHSA-2522-mrjc-m688

References

  • TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
  • TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
  • TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
  • TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
  • TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
See all 157 →

Sources