Apache Airflow: XSS vulnerability in Task Instance Log/Log Details
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs. Users are recommended to upgrade to version 2.9.1, which fixes this issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01559 75th percentileScored 2026-11-07
Fix Fixed Apache Airflow (Apache Software Foundation): 2.9.1apache-airflow (PyPI): 2.9.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow | 2.9.0 to before 2.9.1 | 2.9.1 | Patch available | CNA |
| — | apache-airflow (PyPI) | 2.9.0 to before 2.9.1 | 2.9.1 | Patch available | GHSA-52gm-qmg3-r4qp |
- Apache Airflow VendorApache Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available CNA
- apache-airflow (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-52gm-qmg3-r4qp
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:airflow:2.9.0:-:*:*:*:*:*:* | 2.9.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:airflow:2.9.0:beta1:*:*:*:*:*:* | 2.9.0 beta1 | Vulnerable | Apache |
| cpe:2.3:a:apache:airflow:2.9.0:beta2:*:*:*:*:*:* | 2.9.0 beta2 | Vulnerable | Apache |
| cpe:2.3:a:apache:airflow:2.9.0:rc1:*:*:*:*:*:* | 2.9.0 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:airflow:2.9.0:rc2:*:*:*:*:*:* | 2.9.0 rc2 | Vulnerable | Apache |
| cpe:2.3:a:apache:airflow:2.9.0:rc3:*:*:*:*:*:* | 2.9.0 rc3 | Vulnerable | Apache |
- cpe:2.3:a:apache:airflow:2.9.0:-:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Apache
- cpe:2.3:a:apache:airflow:2.9.0:beta1:*:*:*:*:*:* Versions 2.9.0 beta1 Vulnerable ·Apache
- cpe:2.3:a:apache:airflow:2.9.0:beta2:*:*:*:*:*:* Versions 2.9.0 beta2 Vulnerable ·Apache
- cpe:2.3:a:apache:airflow:2.9.0:rc1:*:*:*:*:*:* Versions 2.9.0 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:airflow:2.9.0:rc2:*:*:*:*:*:* Versions 2.9.0 rc2 Vulnerable ·Apache
- cpe:2.3:a:apache:airflow:2.9.0:rc3:*:*:*:*:*:* Versions 2.9.0 rc3 Vulnerable ·Apache
Remediation
- Fix · CNA Apache Airflow (Apache Software Foundation) Fixed in 2.9.1
- Fix · GHSA-52gm-qmg3-r4qp apache-airflow (PyPI) Fixed in 2.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32077
- 2026-10-03 Alias added: GHSA-52gm-qmg3-r4qp
References
Advisory 3
More Apache Airflow vulnerabilities
- TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
- TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
- TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
- TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
- TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
- TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
Sources
- CVE-2024-32077 · CVE Program
- CVE-2024-32077 · NVD
- FIRST EPSS
- GHSA-52gm-qmg3-r4qp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences