Read the docs
TI-2024-21482 Aliases CVE-2024-32595GHSA-hm2q-8f77-qrwh

WordPress WP Helper Premium plugin < 4.6.0 - Reflected Cross Site Scripting (XSS) vulnerability

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mat Bao Corp WP Helper Premium allows Reflected XSS.This issue affects WP Helper Premium: from n/a before 4.6.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00394 33rd percentileScored 2026-11-07
Fix Fixed WP Helper Premium (Mat Bao Corp): 4.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Mat Bao CorpWP Helper Premiumbefore 4.6.04.6.0Patch availableCNA
  • WP Helper Premium VendorMat Bao Corp Affected before 4.6.0 Fixed in 4.6.0 Patch available CNA

Remediation

  • Fix · CNA WP Helper Premium (Mat Bao Corp) Fixed in 4.6.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-32595
  2. 2026-10-03 Alias added: GHSA-hm2q-8f77-qrwh

References

  • TI-2023-00424 Cross-site scripting in WP Helper Lite Wordpress Plugin CVSS 3.1MEDIUM 6.1
  • TI-2023-25116 WordPress WP Helper Premium Plugin <= 4.5.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2025-18454 WordPress WP Helper Premium plugin <= 4.6.1 - Broken Access Control vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-08415 WP Helper Premium <= 4.6.1 - Missing Authorization in whp_smtp_send_mail_test CVSS 3.1MEDIUM 5.3

Sources