Read the docs
TI-2024-21554 Aliases CVE-2024-32674GHSA-3vp4-9c6g-mcq2

Cross-site scripting in Team Heateor Heateor Social Login WordPress

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

Heateor Social Login WordPress prior to 1.1.32 contains a cross-site scripting vulnerability. If this vulnerability is exploited, an arbitrary script may be executed on the web browser of the user who accessed the website using the product.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00341 27th percentileScored 2026-11-07
Fix Fixed Heateor Social Login WordPress (Heateor): 1.1.32

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Team HeateorHeateor Social Login WordPressbefore 1.1.321.1.32Patch availableCNA
  • Heateor Social Login WordPress VendorTeam Heateor Affected before 1.1.32 Fixed in 1.1.32 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:heateor:social_login:*:*:*:*:*:wordpress:*:*before 1.1.32VulnerableTeam Heateor
  • cpe:2.3:a:heateor:social_login:*:*:*:*:*:wordpress:*:* Versions before 1.1.32 Vulnerable ·Team Heateor

Remediation

  • Fix · CNA Heateor Social Login WordPress (Heateor) Fixed in 1.1.32

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-32674
  2. 2026-10-03 Alias added: GHSA-3vp4-9c6g-mcq2

References

  • TI-2024-09300 Heateor Social Login WordPress <= 1.1.35 - Authentication Bypass via Disqus OAuth provider CVSS 3.1HIGH 8.1
  • TI-2024-23575 WordPress Heateor Social Login WordPress plugin <= 1.1.32 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-16243 WordPress Heateor Social Login Plugin <= 1.1.30 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2024-23576 WordPress Heateor Social Login WordPress plugin <= 1.1.32 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5

Sources