WordOps through 3.20.0 has a wo/cli/plugins/stack_pref.py TOCTOU race condition because…
Priority LOW 35CWE-367Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
WordOps through 3.20.0 has a wo/cli/plugins/stack_pref.py TOCTOU race condition because the conf_path os.open does not use a mode parameter during file creation.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00181 7th percentileScored 2026-11-07
Fix Fixed wordops (PyPI): 3.21.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | wordops (PyPI) | before 3.21.0 | 3.21.0 | Patch available | GHSA-23qq-p4gq-gc2g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- wordops (PyPI) Vendor— Affected before 3.21.0 Fixed in 3.21.0 Patch available GHSA-23qq-p4gq-gc2g
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordopsproject:wordops:*:*:*:*:*:*:*:* | — | — | — |
- cpe:2.3:a:wordopsproject:wordops:*:*:*:*:*:*:*:* Versions — — ·—
Remediation
- Fix · GHSA-23qq-p4gq-gc2g wordops (PyPI) Fixed in 3.21.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34528
- 2026-10-03 Alias added: GHSA-23qq-p4gq-gc2g
References
Other 5
- https://github.com/WordOps/WordOps/issues/611
- https://github.com/WordOps/WordOps/blob/ecf20192c7853925e2cb3f8c8378cd0d86ca0d62/wo/cli/plugins/stack_pref.py#L77
- https://github.com/WordOps/WordOps/commit/31353f0fef14ad8bc1f61c028971bd30b9e1909b
- https://github.com/WordOps/WordOps
- https://github.com/pypa/advisory-database/tree/main/vulns/wordops/PYSEC-2024-175.yaml
Sources
- CVE-2024-34528 · CVE Program
- CVE-2024-34528 · NVD
- FIRST EPSS
- GHSA-23qq-p4gq-gc2g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences