Read the docs
TI-2024-23044 Aliases CVE-2024-34753GHSA-hpcw-9w82-7fr9

WordPress Radio Player plugin <= 2.0.73 - Broken Access Control vulnerability

Priority LOW 30CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

Missing Authorization vulnerability in SoftLab Radio Player.This issue affects Radio Player: from n/a through 2.0.73.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00339 27th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
SoftLabRadio Playerup to 2.0.73—No fix listedCNA
  • Radio Player VendorSoftLab Affected up to 2.0.73 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:softlabbd:radio_player:*:*:*:*:*:wordpress:*:*before 2.0.74VulnerableSoftLab
  • cpe:2.3:a:softlabbd:radio_player:*:*:*:*:*:wordpress:*:* Versions before 2.0.74 Vulnerable ·SoftLab

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-34753
  2. 2026-10-03 Alias added: GHSA-hpcw-9w82-7fr9

References

  • TI-2024-07663 Cross-site scripting in princeahmed Radio Player – Live Shoutcast, Icecast and Any Audio… CVSS 3.1MEDIUM 6.4
  • TI-2023-03736 Radio Player <= 2.0.73 - Missing Authorization to Player Deletion CVSS 3.1MEDIUM 5.3
  • TI-2023-03738 Radio Player <= 2.0.73 - Missing Authorization to Settings Update CVSS 3.1MEDIUM 5.3
  • TI-2023-03737 Radio Player <= 2.0.73 - Missing Authorization to Player Update CVSS 3.1MEDIUM 5.3
  • TI-2024-19587 WordPress Radio Player plugin <= 2.0.73 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5

Sources