php-censor v2.1.4 and fixed in v.2.1.5 was discovered to utilize a weak hashing algorithm…
Priority MEDIUM 63CWE-328Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-327.
Summary
php-censor v2.1.4 and fixed in v.2.1.5 was discovered to utilize a weak hashing algorithm for its remember_key value. This allows attackers to bruteforce to bruteforce the remember_key value to gain access to accounts that have checked "remember me" when logging in.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00283 20th percentileScored 2026-11-07
Fix Fixed php-censor/php-censor (Packagist): 2.1.5, 2.0.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | php-censor/php-censor (Packagist) | 2.1.0 to before 2.1.5 | 2.1.5 | Patch available | GHSA-fqw7-839j-hvxj |
| — | php-censor/php-censor (Packagist) | before 2.0.13 | 2.0.13 | Patch available | GHSA-fqw7-839j-hvxj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- php-censor/php-censor (Packagist) Vendor— Affected 2.1.0 to before 2.1.5 Fixed in 2.1.5 Patch available GHSA-fqw7-839j-hvxj
- php-censor/php-censor (Packagist) Vendor— Affected before 2.0.13 Fixed in 2.0.13 Patch available GHSA-fqw7-839j-hvxj
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php-censor:php-censor:2.1.5:*:*:*:*:*:*:* | 2.1.5 | — | — |
- cpe:2.3:a:php-censor:php-censor:2.1.5:*:*:*:*:*:*:* Versions 2.1.5 — ·—
Remediation
- Fix · GHSA-fqw7-839j-hvxj php-censor/php-censor (Packagist) Fixed in 2.1.5 Advisory →
- Fix · GHSA-fqw7-839j-hvxj php-censor/php-censor (Packagist) Fixed in 2.0.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34914
- 2026-10-03 Alias added: GHSA-fqw7-839j-hvxj
References
Sources
- CVE-2024-34914 · CVE Program
- CVE-2024-34914 · NVD
- FIRST EPSS
- GHSA-fqw7-839j-hvxj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences