Path traversal in WPFactory Download Plugins and Themes from Dashboard
Priority LOW 32CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
Path traversal vulnerability exists in Download Plugins and Themes from Dashboard versions prior to 1.8.6. If this vulnerability is exploited, a remote authenticated attacker with "switch_themes" privilege may obtain arbitrary files on the server.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00669 52nd percentileScored 2026-11-07
Fix Fixed Download Plugins and Themes from Dashboard (WPFactory LLC): 1.8.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Download Plugins and Themes from Dashboard (WPFactory LLC) Fixed in 1.8.6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-35162
- 2026-10-03 Alias added: GHSA-5qvg-g2v8-cghm
References
More WPFactory vulnerabilities
- TI-2023-00058 EAN for WooCommerce < 4.4.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-02512 File Renaming on Upload < 2.5.2 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2026-80051 SQL injection in WordPress Product Filter by WBW plugin CVSS 3.1CRITICAL 9.3
- TI-2025-22716 WordPress Advanced WooCommerce Product Sales Reporting plugin <= 4.1.1 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2026-20178 WordPress Advanced WooCommerce Product Sales Reporting plugin <= 4.1.3 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2024-32898 WordPress Customer Email Verification for WooCommerce plugin <= 2.8.10 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
Sources
- CVE-2024-35162 · CVE Program
- CVE-2024-35162 · NVD
- FIRST EPSS
- GHSA-5qvg-g2v8-cghm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences