Cross-site scripting in aviplugins.com WP Booking
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting vulnerability exists in WP Booking versions prior to 2.4.5. If this vulnerability is exploited, an arbitrary script may be executed on the web browser of the user who is accessing the web site using the product.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0037 31st percentileScored 2026-11-07
Fix Fixed WP Booking (aviplugins.com): 2.4.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| aviplugins.com | WP Booking | before 2.4.5 | 2.4.5 | Patch available | CNA |
- WP Booking Vendoraviplugins.com Affected before 2.4.5 Fixed in 2.4.5 Patch available CNA
Remediation
- Fix · CNA WP Booking (aviplugins.com) Fixed in 2.4.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-35297
References
More aviplugins.com vulnerabilities
- TI-2025-23627 WordPress WP Easy Poll Plugin <= 2.2.9 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2025-18281 WordPress Contact Form With Shortcode plugin <= 4.2.5 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2025-39056 WordPress Custom Post Type Attachment plugin <= 3.4.6 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-33249 WordPress Thumbnail Editor plugin <= 2.3.3 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-31955 WordPress WP Register Profile With Shortcode plugin <= 3.6.3 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-36344 WordPress Login Widget With Shortcode plugin <= 6.1.2 - Open Redirection vulnerability CVSS 3.1MEDIUM 4.7
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences