Read the docs
TI-2024-23405 Aliases CVE-2024-35374GHSA-j6cv-98jx-mrwr

Mocodo Mocodo Online 4.2.6 and below does not properly sanitize the sql_case input field…

Priority MEDIUM 54CWE-77Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution, SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-77 and CWE-89.

Summary

Mocodo Mocodo Online 4.2.6 and below does not properly sanitize the sql_case input field in /web/generate.php, allowing remote attackers to execute arbitrary commands and potentially command injection, leading to remote code execution (RCE) under certain conditions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02767 86th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mocodo (PyPI): 4.2.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mocodo (PyPI)before 4.2.74.2.7Patch availableGHSA-j6cv-98jx-mrwr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mocodo (PyPI) Vendor— Affected before 4.2.7 Fixed in 4.2.7 Patch available GHSA-j6cv-98jx-mrwr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mocodo:mocodo_online:*:*:*:*:*:*:*:*up to 4.2.6VulnerableMocodo
  • cpe:2.3:a:mocodo:mocodo_online:*:*:*:*:*:*:*:* Versions up to 4.2.6 Vulnerable ·Mocodo

Remediation

  • Fix · GHSA-j6cv-98jx-mrwr mocodo (PyPI) Fixed in 4.2.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-35374
  2. 2026-10-03 Alias added: GHSA-j6cv-98jx-mrwr

References

  • TI-2024-23404 Mocodo Mocodo Online 4.2.6 and below is vulnerable to Remote Code Execution via /web/rewrite.php. CVSS 3.1CRITICAL 9.8

Sources