tee: optee: Fix kernel panic caused by incorrect error handling
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: tee: optee: Fix kernel panic caused by incorrect error handling The error path while failing to register devices on the TEE bus has a bug leading to kernel panic as follows: [ 15.398930] Unable to handle kernel paging request at virtual address ffff07ed00626d7c [ 15.406913] Mem abort info: [ 15.409722] ESR = 0x0000000096000005 [ 15.413490] EC = 0x25: DABT (current EL), IL = 32 bits [ 15.418814] SET = 0, FnV = 0 [ 15.421878] EA = 0, S1PTW = 0 [ 15.425031] FSC = 0x05: level 1 translation fault [ 15.429922] Data abort info: [ 15.432813] ISV = 0, ISS = 0x00000005, ISS2 = 0x00000000 [ 15.438310] CM = 0, WnR = 0, TnD = 0, TagAccess = 0 [ 15.443372] GCS = 0, Overlay = 0, DirtyBit = 0, Xs = 0 [ 15.448697] swapper pgtable: 4k pages, 48-bit VAs, pgdp=00000000d9e3e000 [ 15.455413] [ffff07ed00626d7c] pgd=1800000bffdf9003, p4d=1800000bffdf9003, pud=0000000000000000 [ 15.464146] Internal error: Oops: 0000000096000005 [#1] PREEMPT SMP Commit 7269cba53d90 ("tee: optee: Fix supplicant based device enumeration") lead to the introduction of this bug. So fix it appropriately.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.10.204 to before 5.10.215; 5.15.143 to before 5.15.154; 6.1.68 to before 6.1.84; 6.6.7 to before 6.6.24 | 5.10.215, 5.15.154, 6.1.84, 6.6.24 | Patch available | CNA |
| Linux | Linux | 6.7 and later | 5.10.215, 5.15.154, 6.1.84, 6.6.24, 6.7.12, 6.8 | Patch available | CNA |
- Linux VendorLinux Affected 5.10.204 to before 5.10.215; 5.15.143 to before 5.15.154; 6.1.68 to before 6.1.84; 6.6.7 to before 6.6.24 Fixed in 5.10.215, 5.15.154, 6.1.84, 6.6.24 Patch available CNA
- Linux VendorLinux Affected 6.7 and later Fixed in 5.10.215, 5.15.154, 6.1.84, 6.6.24, 6.7.12, 6.8 Patch available CNA
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.10.204 to before 5.10.215; 5.15.143 to before 5.15.154; 6.1.68 to before 6.1.84; 6.6.7 to before 6.6.24; 6.7.1 to before 6.7.12 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.7:-:*:*:*:*:*:* | 6.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.7:rc5:*:*:*:*:*:* | 6.7 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.7:rc6:*:*:*:*:*:* | 6.7 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.7:rc7:*:*:*:*:*:* | 6.7 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.7:rc8:*:*:*:*:*:* | 6.7 rc8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* | 6.8 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* | 6.8 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* | 6.8 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* | 6.8 rc4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.10.204 to before 5.10.215; 5.15.143 to before 5.15.154; 6.1.68 to before 6.1.84; 6.6.7 to before 6.6.24; 6.7.1 to before 6.7.12 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.7:-:*:*:*:*:*:* Versions 6.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.7:rc5:*:*:*:*:*:* Versions 6.7 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.7:rc6:*:*:*:*:*:* Versions 6.7 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.7:rc7:*:*:*:*:*:* Versions 6.7 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.7:rc8:*:*:*:*:*:* Versions 6.7 rc8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc1:*:*:*:*:*:* Versions 6.8 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc2:*:*:*:*:*:* Versions 6.8 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc3:*:*:*:*:*:* Versions 6.8 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc4:*:*:*:*:*:* Versions 6.8 rc4 Vulnerable ·Linux
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* | 6.8 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc6:*:*:*:*:*:* | 6.8 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.8:rc7:*:*:*:*:*:* | 6.8 rc7 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:6.8:rc5:*:*:*:*:*:* Versions 6.8 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc6:*:*:*:*:*:* Versions 6.8 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.8:rc7:*:*:*:*:*:* Versions 6.8 rc7 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.215, 5.15.154, 6.1.84, 6.6.24
- Fix · CNA Linux (Linux) Fixed in 5.10.215, 5.15.154, 6.1.84, 6.6.24, 6.7.12, 6.8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-35785
- 2026-10-03 Alias added: GHSA-vvqv-hjv4-6q76
References
Patch 6
- https://git.kernel.org/stable/c/bc40ded92af55760d12bec8222d4108de725dbe4
- https://git.kernel.org/stable/c/4b12ff5edd141926d49c9ace4791adf3a4902fe7
- https://git.kernel.org/stable/c/e5b5948c769aa1ebf962dddfb972f87d8f166f95
- https://git.kernel.org/stable/c/520f79c110ff712b391b3d87fcacf03c74bc56ee
- https://git.kernel.org/stable/c/bfa344afbe472a9be08f78551fa2190c1a07d7d3
- https://git.kernel.org/stable/c/95915ba4b987cf2b222b0f251280228a1ff977ac
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-35785 · CVE Program
- CVE-2024-35785 · NVD
- FIRST EPSS
- GHSA-vvqv-hjv4-6q76 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-35785 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences