of: dynamic: Synchronize of_changeset_destroy() with the devlink removals
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-401.
Summary
In the Linux kernel, the following vulnerability has been resolved: of: dynamic: Synchronize of_changeset_destroy() with the devlink removals In the following sequence: 1) of_platform_depopulate() 2) of_overlay_remove() During the step 1, devices are destroyed and devlinks are removed. During the step 2, OF nodes are destroyed but __of_changeset_entry_destroy() can raise warnings related to missing of_node_put(): ERROR: memory leak, expected refcount 1 instead of 2 ... Indeed, during the devlink removals performed at step 1, the removal itself releasing the device (and the attached of_node) is done by a job queued in a workqueue and so, it is done asynchronously with respect to function calls. When the warning is present, of_node_put() will be called but wrongly too late from the workqueue job. In order to be sure that any ongoing devlink removals are done before the of_node destruction, synchronize the of_changeset_destroy() with the devlink removals.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.10.42 to before 5.10.215; 5.12.9 to before 5.13 | 5.10.215, 5.13 | Patch available | CNA |
| Linux | Linux | 5.13 and later | 5.10.215, 5.15.154, 6.1.85, 6.6.26, 6.8.5, 6.9 | Patch available | CNA |
- Linux VendorLinux Affected 5.10.42 to before 5.10.215; 5.12.9 to before 5.13 Fixed in 5.10.215, 5.13 Patch available CNA
- Linux VendorLinux Affected 5.13 and later Fixed in 5.10.215, 5.15.154, 6.1.85, 6.6.26, 6.8.5, 6.9 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.10.42 to before 5.10.215; 5.12.9 to before 5.13; 5.13.1 to before 5.15.154; 5.16 to before 6.1.85; 6.2 to before 6.6.26; 6.7 to before 6.8.5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:-:*:*:*:*:*:* | 5.13 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc4:*:*:*:*:*:* | 5.13 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc5:*:*:*:*:*:* | 5.13 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc6:*:*:*:*:*:* | 5.13 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.13:rc7:*:*:*:*:*:* | 5.13 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc1:*:*:*:*:*:* | 6.9 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.9:rc2:*:*:*:*:*:* | 6.9 rc2 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.10.42 to before 5.10.215; 5.12.9 to before 5.13; 5.13.1 to before 5.15.154; 5.16 to before 6.1.85; 6.2 to before 6.6.26; 6.7 to before 6.8.5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:-:*:*:*:*:*:* Versions 5.13 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc4:*:*:*:*:*:* Versions 5.13 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc5:*:*:*:*:*:* Versions 5.13 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc6:*:*:*:*:*:* Versions 5.13 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.13:rc7:*:*:*:*:*:* Versions 5.13 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc1:*:*:*:*:*:* Versions 6.9 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.9:rc2:*:*:*:*:*:* Versions 6.9 rc2 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.215, 5.13
- Fix · CNA Linux (Linux) Fixed in 5.10.215, 5.15.154, 6.1.85, 6.6.26, 6.8.5, 6.9
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-35879
- 2026-10-03 Alias added: GHSA-x58g-pgf5-4jp7
References
Patch 6
- https://git.kernel.org/stable/c/3127b2ee50c424a96eb3559fbb7b43cf0b111c7a
- https://git.kernel.org/stable/c/3ee2424107546d882e1ddd75333ca9c32879908c
- https://git.kernel.org/stable/c/7b6df050c45a1ea158fd50bc32a8e1447dd1e951
- https://git.kernel.org/stable/c/801c8b8ec5bfb3519566dff16a5ecd48302fca82
- https://git.kernel.org/stable/c/ae6d76e4f06c37a623e357e79d49b17411db6f5c
- https://git.kernel.org/stable/c/8917e7385346bd6584890ed362985c219fe6ae84
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-35879 · CVE Program
- CVE-2024-35879 · NVD
- FIRST EPSS
- GHSA-x58g-pgf5-4jp7 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-35879 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences