Apache NiFi: Improper Neutralization of Input in Parameter Context Description
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache NiFi | 1.10.0 – 1.26.0; 2.0.0-M1 – 2.0.0-M3 | — | No fix listed | CNA |
| — | org.apache.nifi:nifi-web-ui (Maven) | 1.10.0 to before 1.27.0 | 1.27.0 | Patch available | GHSA-h658-qqv9-qwv8 |
| — | org.apache.nifi:nifi-web-ui (Maven) | 2.0.0-M1 to before 2.0.0-M4 | 2.0.0-M4 | Patch available | GHSA-h658-qqv9-qwv8 |
- Apache NiFi VendorApache Affected 1.10.0 – 1.26.0; 2.0.0-M1 – 2.0.0-M3 Fixed in — No fix listed CNA
- org.apache.nifi:nifi-web-ui (Maven) Vendor— Affected 1.10.0 to before 1.27.0 Fixed in 1.27.0 Patch available GHSA-h658-qqv9-qwv8
- org.apache.nifi:nifi-web-ui (Maven) Vendor— Affected 2.0.0-M1 to before 2.0.0-M4 Fixed in 2.0.0-M4 Patch available GHSA-h658-qqv9-qwv8
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* | 1.10.0 to before 1.27.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone1:*:*:*:*:*:* | 2.0.0 milestone1 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc1:*:*:*:*:*:* | 2.0.0 milestone1-rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc2:*:*:*:*:*:* | 2.0.0 milestone1-rc2 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc3:*:*:*:*:*:* | 2.0.0 milestone1-rc3 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc4:*:*:*:*:*:* | 2.0.0 milestone1-rc4 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc5:*:*:*:*:*:* | 2.0.0 milestone1-rc5 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc6:*:*:*:*:*:* | 2.0.0 milestone1-rc6 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone2:*:*:*:*:*:* | 2.0.0 milestone2 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone2-rc1:*:*:*:*:*:* | 2.0.0 milestone2-rc1 | Vulnerable | Apache |
- cpe:2.3:a:apache:nifi:*:*:*:*:*:*:*:* Versions 1.10.0 to before 1.27.0 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone1:*:*:*:*:*:* Versions 2.0.0 milestone1 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc1:*:*:*:*:*:* Versions 2.0.0 milestone1-rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc2:*:*:*:*:*:* Versions 2.0.0 milestone1-rc2 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc3:*:*:*:*:*:* Versions 2.0.0 milestone1-rc3 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc4:*:*:*:*:*:* Versions 2.0.0 milestone1-rc4 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc5:*:*:*:*:*:* Versions 2.0.0 milestone1-rc5 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone1-rc6:*:*:*:*:*:* Versions 2.0.0 milestone1-rc6 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone2:*:*:*:*:*:* Versions 2.0.0 milestone2 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone2-rc1:*:*:*:*:*:* Versions 2.0.0 milestone2-rc1 Vulnerable ·Apache
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:nifi:2.0.0:milestone2-rc2:*:*:*:*:*:* | 2.0.0 milestone2-rc2 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone2-rc3:*:*:*:*:*:* | 2.0.0 milestone2-rc3 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone2-rc4:*:*:*:*:*:* | 2.0.0 milestone2-rc4 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone3:*:*:*:*:*:* | 2.0.0 milestone3 | Vulnerable | Apache |
| cpe:2.3:a:apache:nifi:2.0.0:milestone3-rc1:*:*:*:*:*:* | 2.0.0 milestone3-rc1 | Vulnerable | Apache |
- cpe:2.3:a:apache:nifi:2.0.0:milestone2-rc2:*:*:*:*:*:* Versions 2.0.0 milestone2-rc2 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone2-rc3:*:*:*:*:*:* Versions 2.0.0 milestone2-rc3 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone2-rc4:*:*:*:*:*:* Versions 2.0.0 milestone2-rc4 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone3:*:*:*:*:*:* Versions 2.0.0 milestone3 Vulnerable ·Apache
- cpe:2.3:a:apache:nifi:2.0.0:milestone3-rc1:*:*:*:*:*:* Versions 2.0.0 milestone3-rc1 Vulnerable ·Apache
Remediation
- Fix · GHSA-h658-qqv9-qwv8 org.apache.nifi:nifi-web-ui (Maven) Fixed in 1.27.0 Advisory →
- Fix · GHSA-h658-qqv9-qwv8 org.apache.nifi:nifi-web-ui (Maven) Fixed in 2.0.0-M4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-37389
- 2026-10-03 Alias added: GHSA-h658-qqv9-qwv8
References
Advisory 2
More Apache Nifi vulnerabilities
- TI-2023-17293 Apache NiFi: Potential Code Injection with Database Services using H2 CVSS 3.1HIGH 8.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-07411 Deserialization of untrusted data in Apache Commons Beanutils CVSS 3.1HIGH 7.3
- TI-2017-11471 Improper input validation in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2018-01212 XML external entity injection in Apache NiFi CVSS 3.0CRITICAL 9.8
- TI-2021-03489 Deserialization of untrusted data in jackson-databind CVSS 3.1HIGH 8.1
Sources
- CVE-2024-37389 · CVE Program
- CVE-2024-37389 · NVD
- FIRST EPSS
- GHSA-h658-qqv9-qwv8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences